FreePBX | Register | Issues | Wiki | Portal | Support

All SIP stations lose registration from time to time


#1

from time to time i keep facing all phones disconnected and lose registration with freepbx . and nothing help unless i reboot the whole server . i tried to restart asterisk and restart apache but without any success. also i notice that sometimes i cant access the web admin interface for the freepbx.

network is ok during this problem . every thing looks normal except all phone suddenly lose registration
. all phone still have the same ip . all phone and the asterisk server are in the same LAN . no VLAN .
and after i reboot the freepbx server all phone immediately register and work fine for random times it could be days or weeks . some times hours.

system info
Asterisk 11.4.0
pbx-version
4.211.64-5
CentOS release 6.4
2.6.32-358.0.1.el6.x86_64 #1 SMP Wed Feb 27 06:06:45 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
System Information
Manufacturer: IBM
Product Name: System x3300 M4
DAHDI Version: 2.7.0 Echo Canceller: HWEC Sangoma A400 24 port . 3 as FXO
Spa 504G

Also i have another question not related to this issue . i need the sip stations to show the Caller ID when they start calling some ext for the first time .

ex:

when A calls B . the Sip phone show incoming call from caller Id A ( then it stored the name A linked to his ext in the calling history ) and when B call back A Ext Number , it display the call is going to A name not his Ext Number
.

but

if B was trying to call A ext Number for the first time ( meaning there is no call history in the SIP phone before from A to B ) and if there is no Name for A ext Number in the phone directory . it only show A ext Number and don’t get any name from Asterisk .

i need to force the phone to grep the name which is stored in the Asterisk.


(Dws4wdr) #2

Did you ever find a resolution to your phones loosing registration? I have a server doing the exact same thing.


(Itzik) #3

Hi @dwilson,

This is a 4 year old topic, a bunch of things have changed since…

I suggest creating a new topic, make sure to include as much details possible of your setup etc.

Thanks