All outbound calls going to cannot-complete-as-dialed

I did my normal Module Admin update and after the update we have not been able to make any outbound calls. here is the full log message when i dial

[2018-11-03 13:24:45] VERBOSE[11844][C-0000003e] pbx.c: Executing [[email protected]:1] Macro(“SIP/290-0000000b”, “user-callerid,LIMIT”) in new stack
[2018-11-03 13:24:45] VERBOSE[11844][C-0000003e] pbx.c: Executing [[email protected]:1] Set(“SIP/290-0000000b”, “TOUCH_MONITOR=1541265885.17”) in new stack
[2018-11-03 13:24:45] VERBOSE[11844][C-0000003e] pbx.c: Executing [[email protected]:2] Set(“SIP/290-0000000b”, “AMPUSER=290”) in new stack
[2018-11-03 13:24:45] VERBOSE[11844][C-0000003e] pbx.c: Executing [[email protected]:3] GotoIf(“SIP/290-0000000b”, “0?report”) in new stack
[2018-11-03 13:24:45] VERBOSE[11844][C-0000003e] pbx.c: Executing [[email protected]:4] ExecIf(“SIP/290-0000000b”, “1?Set(REALCALLERIDNUM=290)”) in new stack
[2018-11-03 13:24:45] VERBOSE[11844][C-0000003e] pbx.c: Executing [[email protected]:5] Set(“SIP/290-0000000b”, “AMPUSER=290”) in new stack
[2018-11-03 13:24:45] VERBOSE[11844][C-0000003e] pbx.c: Executing [[email protected]:6] GotoIf(“SIP/290-0000000b”, “0?limit”) in new stack
[2018-11-03 13:24:45] VERBOSE[11844][C-0000003e] pbx.c: Executing [[email protected]:7] Set(“SIP/290-0000000b”, “AMPUSERCIDNAME=Maulik Patel”) in new stack
[2018-11-03 13:24:45] VERBOSE[11844][C-0000003e] pbx.c: Executing [[email protected]:8] ExecIf(“SIP/290-0000000b”, “0?Set(__CIDMASQUERADING=TRUE)”) in new stack
[2018-11-03 13:24:45] VERBOSE[11844][C-0000003e] pbx.c: Executing [[email protected]:9] GotoIf(“SIP/290-0000000b”, “0?report”) in new stack
[2018-11-03 13:24:45] VERBOSE[11844][C-0000003e] pbx.c: Executing [[email protected]:10] Set(“SIP/290-0000000b”, “AMPUSERCID=290”) in new stack
[2018-11-03 13:24:45] VERBOSE[11844][C-0000003e] pbx.c: Executing [[email protected]:11] Set(“SIP/290-0000000b”, “__DIAL_OPTIONS=Ttr”) in new stack
[2018-11-03 13:24:45] VERBOSE[11844][C-0000003e] pbx.c: Executing [[email protected]:12] Set(“SIP/290-0000000b”, “CALLERID(all)=“Maulik Patel” <290>”) in new stack
[2018-11-03 13:24:45] VERBOSE[11844][C-0000003e] pbx.c: Executing [[email protected]:13] GotoIf(“SIP/290-0000000b”, “0?limit”) in new stack
[2018-11-03 13:24:45] VERBOSE[11844][C-0000003e] pbx.c: Executing [[email protected]:14] ExecIf(“SIP/290-0000000b”, “1?Set(GROUP(concurrency_limit)=290)”) in new stack
[2018-11-03 13:24:45] VERBOSE[11844][C-0000003e] pbx.c: Executing [[email protected]:15] ExecIf(“SIP/290-0000000b”, “0?Set(CHANNEL(language)=)”) in new stack
[2018-11-03 13:24:45] VERBOSE[11844][C-0000003e] pbx.c: Executing [[email protected]:16] NoOp(“SIP/290-0000000b”, “Macro Depth is 1”) in new stack
[2018-11-03 13:24:45] VERBOSE[11844][C-0000003e] pbx.c: Executing [[email protected]:17] GotoIf(“SIP/290-0000000b”, “1?report2:macroerror”) in new stack
[2018-11-03 13:24:45] VERBOSE[11844][C-0000003e] pbx_builtins.c: Goto (macro-user-callerid,s,18)
[2018-11-03 13:24:45] VERBOSE[11844][C-0000003e] pbx.c: Executing [[email protected]:18] GotoIf(“SIP/290-0000000b”, “1?continue”) in new stack
[2018-11-03 13:24:45] VERBOSE[11844][C-0000003e] pbx_builtins.c: Goto (macro-user-callerid,s,37)
[2018-11-03 13:24:45] VERBOSE[11844][C-0000003e] pbx.c: Executing [[email protected]:37] Set(“SIP/290-0000000b”, “CALLERID(number)=290”) in new stack
[2018-11-03 13:24:45] VERBOSE[11844][C-0000003e] pbx.c: Executing [[email protected]:38] Set(“SIP/290-0000000b”, “CALLERID(name)=Maulik Patel”) in new stack
[2018-11-03 13:24:45] VERBOSE[11844][C-0000003e] pbx.c: Executing [[email protected]:39] GotoIf(“SIP/290-0000000b”, “0?cnum”) in new stack
[2018-11-03 13:24:45] VERBOSE[11844][C-0000003e] pbx.c: Executing [[email protected]:40] Set(“SIP/290-0000000b”, “CDR(cnam)=Maulik Patel”) in new stack
[2018-11-03 13:24:45] VERBOSE[11844][C-0000003e] pbx.c: Executing [[email protected]:41] Set(“SIP/290-0000000b”, “CDR(cnum)=290”) in new stack
[2018-11-03 13:24:45] VERBOSE[11844][C-0000003e] pbx.c: Executing [[email protected]:42] Set(“SIP/290-0000000b”, “CHANNEL(language)=en”) in new stack
[2018-11-03 13:24:45] VERBOSE[11844][C-0000003e] pbx.c: Executing [[email protected]:2] Set(“SIP/290-0000000b”, “ROUTEUSER=290”) in new stack
[2018-11-03 13:24:45] VERBOSE[11844][C-0000003e] pbx.c: Executing [[email protected]:3] Set(“SIP/290-0000000b”, “ROUTEUSER=290”) in new stack
[2018-11-03 13:24:45] VERBOSE[11844][C-0000003e] pbx.c: Executing [[email protected]:4] GotoIf(“SIP/290-0000000b”, “1?notblind”) in new stack
[2018-11-03 13:24:45] VERBOSE[11844][C-0000003e] pbx_builtins.c: Goto (from-internal,4042566505,7)
[2018-11-03 13:24:45] VERBOSE[11844][C-0000003e] pbx.c: Executing [[email protected]:7] GotoIf(“SIP/290-0000000b”, “1?restrictedroute-cfcd208495d565ef66e7dff9f98764da,4042566505,2:outbound-allroutes,4042566505,2”) in new stack
[2018-11-03 13:24:45] VERBOSE[11844][C-0000003e] pbx_builtins.c: Goto (restrictedroute-cfcd208495d565ef66e7dff9f98764da,4042566505,2)
[2018-11-03 13:24:45] VERBOSE[11844][C-0000003e] pbx.c: Channel ‘SIP/290-0000000b’ sent to invalid extension: context,exten,priority=restrictedroute-cfcd208495d565ef66e7dff9f98764da,4042566505,2
[2018-11-03 13:24:45] VERBOSE[11844][C-0000003e] pbx.c: Executing [[email protected]:1] Goto(“SIP/290-0000000b”, “bad-number,s,1”) in new stack
[2018-11-03 13:24:45] VERBOSE[11844][C-0000003e] pbx_builtins.c: Goto (bad-number,s,1)
[2018-11-03 13:24:45] VERBOSE[11844][C-0000003e] pbx.c: Executing [[email protected]:1] Goto(“SIP/290-0000000b”, “11,1”) in new stack
[2018-11-03 13:24:45] VERBOSE[11844][C-0000003e] pbx_builtins.c: Goto (bad-number,11,1)
[2018-11-03 13:24:45] VERBOSE[11844][C-0000003e] pbx.c: Executing [[email protected]:1] ResetCDR(“SIP/290-0000000b”, “”) in new stack
[2018-11-03 13:24:45] VERBOSE[11844][C-0000003e] pbx.c: Executing [[email protected]:2] NoCDR(“SIP/290-0000000b”, “”) in new stack
[2018-11-03 13:24:45] VERBOSE[11844][C-0000003e] pbx.c: Executing [[email protected]:3] Progress(“SIP/290-0000000b”, “”) in new stack
[2018-11-03 13:24:45] VERBOSE[11844][C-0000003e] pbx.c: Executing [[email protected]:4] Wait(“SIP/290-0000000b”, “1”) in new stack
[2018-11-03 13:24:46] VERBOSE[11844][C-0000003e] pbx.c: Executing [[email protected]:5] Playback(“SIP/290-0000000b”, “silence/1&cannot-complete-as-dialed&check-number-dial-again,noanswer”) in new stack
[2018-11-03 13:24:46] VERBOSE[11844][C-0000003e] file.c: <SIP/290-0000000b> Playing ‘silence/1.ulaw’ (language ‘en’)
[2018-11-03 13:24:47] VERBOSE[11844][C-0000003e] file.c: <SIP/290-0000000b> Playing ‘cannot-complete-as-dialed.ulaw’ (language ‘en’)
[2018-11-03 13:24:50] VERBOSE[11844][C-0000003e] file.c: <SIP/290-0000000b> Playing ‘check-number-dial-again.ulaw’ (language ‘en’)
[2018-11-03 13:25:13] VERBOSE[2127][C-00000040] netsock2.c: Using SIP RTP TOS bits 184
[2018-11-03 13:25:13] VERBOSE[2127][C-00000040] netsock2.c: Using SIP RTP CoS mark 5
[2018-11-03 13:25:13] VERBOSE[11924][C-00000040] pbx.c: Executing [[email protected]:1] Macro(“SIP/290-0000000c”, “user-callerid,LIMIT”) in new stack
[2018-11-03 13:25:13] VERBOSE[11924][C-00000040] pbx.c: Executing [[email protected]:1] Set(“SIP/290-0000000c”, “TOUCH_MONITOR=1541265913.18”) in new stack
[2018-11-03 13:25:13] VERBOSE[11924][C-00000040] pbx.c: Executing [[email protected]:2] Set(“SIP/290-0000000c”, “AMPUSER=290”) in new stack
[2018-11-03 13:25:13] VERBOSE[11924][C-00000040] pbx.c: Executing [[email protected]:3] GotoIf(“SIP/290-0000000c”, “0?report”) in new stack

So figured out the issue, with the update i guess outbound route module got some new settings which by default puts all the extensions in the blocked group. You just have to go to your route and move them to allowed. Hope this helps someone else!

You installed the commercial module extension routing

Thank You for pointing that out, I bought a bundled package of modules for park, and fax and extension module was included in that pack! Thanks Hopefully this will help someone else that is thrown off by it!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.