All inbound routing to voicemail


(Arjones5) #1

Migrating from 14.0.13.24 directly to current on new hardware due to hardware failure. I’m left to migrate it all by hand piece by piece for a small office (3 trunks, 10 phones). I, or so I thought, was complete with all the settings, firewall changes, etc. Outbound calls work just fine, inbound route directly to voicemail every time. The logs are completely useless or they’re buried.

This is the output during 4 inbound call attempts and one outbound success:
https://pastebin.freepbx.org/view/e98144ef

Please halp.


#2

We only see th emachine loading then one successful call that satarted at 22:40:38, when the were the inbound calls seen ?


(Arjones5) #3

That’s what has me confused. I can hear it forward to voicemail but there’s nothing in the log to corroborate it. Different log file maybe?


#4

My call gets “Hello, you’ve reached the Vector Mobile help desk …” Perhaps that’s being played by failover at your provider, a backup PBX system you have, or your old PBX (which is not completely dead).

Edit: the above is not correct; I dialed the wrong number.

Did the old PBX have the same local IP address (10.0.0.60) as the old one had? If not, did you update any port forwarding or other special settings in your router/firewall?


(Arjones5) #5

I get the “The person at extension…” directly from the PBX, the failover is the on-call phone which hasn’t rang. The IP of the server DID change but the firewall rules were updated and the registration for the phones was updated. The only thing that I knowingly changes (IP aside) was moving the extensions from legacy sip to pjsip.


#6

Sorry, I fat-fingered the number on my previous attempt. Now I get “You’ve reached the voicemail of Alex …”, so If you’ve just recorded that (on the new PBX only), then it is reaching the desired machine. Please post a new log.


(Arjones5) #7

Yup - that’s our IT line. Here’s an updated log:
https://pastebin.freepbx.org/view/683b218d


#8

Something is fishy here. The last line of your ‘new’ log has timestamp [2020-02-08 00:43:15] but my post requesting it was at 2020-02-08 00:52 UTC. So, either

  1. your server log does not show UTC time zone or
  2. you didn’t request a new log for the link you posted or
  3. the voicemail greeting came from another server.

I just called your number and left you a test message. Is it on your new server?


(Arjones5) #9

Well that’s embarrassing…it was on the old server. I shut down the old server and now it won’t ring at all which oddly seems like good news. It’s failing over to the on-call phone.

If I set the Asterisk SIP SIP Configuration to Public I can get it to ring but I can’t get outgoing audio.


#10

If you previously had to forward the SIP port in your router, confirm that UDP port 5060 or 5160 (whichever chan_sip is listening on) is forwarded to the new server.

On the General SIP Settings tab, confirm that External Address is your IPv4 public IP address and that Local Networks is correctly set, presumably 10.0.0.0 / 24. On the chan_sip tab, you should have NAT yes, Static IP and the correct External Address value. After changing these settings, restart (not just reload) Asterisk and make a test call in.

If it doesn’t work, at the Asterisk command prompt type
sip set debug on
which will include SIP traces in the normal log file. Make another test call and post the log.


(Arjones5) #11

Nice catch! I had the 5060 port forwarded instead of the 5160. Everything works as expected now.

Thanks for the help!!


#12

Glad to hear that you got it working. If only that other IT problem in Iowa had been as easy to fix :wink:


(system) closed #13

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.