All handset registrations dropped

Asterisk: 13.11.2

Had an issue today where we could no longer make any calls to internal extensions. My handset appeared to be still registered but I tried to initiate a call to another extension and simply got silence, no ring or error. Tried to re-register handset and it failed.

When I looked through the logs, I found a gradual series of entries similar to the following, but for each extension.

[2016-10-20 14:40:54] VERBOSE[11138] res_pjsip/pjsip_configuration.c: Contact 238/sip:[email protected]:5060 has been deleted

Network functionality appeared OK, I was able to ping handset IP both from the PBX server console and my local workstation, PBX server was pingable from my workstation, as were all our other servers, and the FreePBX GUI was still functional.

Rebooting the server fixed the problem (not a graceful solution, but people were shouting at me to get it working).

Is there anything I can dig into to see what the cause of this problem was, or other things I can check in the event this problem happens again? I did look at the “/var/log/asterisk/full” log around the time that the problem started, there seems to be an 8 minute gap in the “/var/log/asterisk/full” file.

Not sure what else I should look at, love any points on how to run this issue down.