All circuits are busy when setting up new flowroute trunk

Flowroute recently changed some things, so i went in and configured a new pjsip trunk following their guide on their site, but i get “all circuits are busy” from my PBX. I used the same trunk settings, such as for CID and manipulations, just changed the sip settings for the new connection to flowroute. I will attach my log output.

Here is my log output.
https://drive.google.com/file/d/1X9JnqQMH6y9jMTifeHFIolXDvFheDtdW/view?usp=sharing

I found this
[2019-03-10 11:37:26] ERROR[17380] res_pjsip.c: Endpoint ‘Flowroute_Primary_New’: Could not create dialog to invalid URI ‘Flowroute_Primary_New’. Is endpoint registered and reachable?
[2019-03-10 11:37:26] ERROR[17380] chan_pjsip.c: Failed to create outgoing session to endpoint ‘Flowroute_Primary_New’
[2019-03-10 11:37:26] WARNING[34037][C-000000ea] app_dial.c: Unable to create channel of type ‘PJSIP’ (cause 3 - No route to destination)

I assume that you are using IP Authentication (not registration) with Flowroute.
Also, that your pjsip is otherwise working (with extensions or another trunk) and that your correct public IP address is shown in My outbound allowed IPs at https://manage.flowroute.com/accounts/interconnection/outbound/ .

Here are my settings for Flowroute trunk:

On General tab, Trunk Name and Outbound CallerID are filled in; everything else left at defaults.

On Dialed Number Manipulation Rules tab, Outbound Dial Prefix is set to 87654321* (replace 87654321 with your actual Tech Prefix); everything else left at defaults.

On pjsip Settings -> General tab, Authentication is set to None and SIP Server set to us-west-or.sip.flowroute.com (substitute appropriate server for your account); everything else left at defaults.

That’s all you should need for outgoing. I don’t have any DIDs with Flowroute so can’t be sure of incoming, but believe that you just have to fill in the Match (Permit) field on the Advanced tab.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.