All Circuits are busy now, Can't dial out SPA3102 FreePBX 16, please help?

I have few computers connected with PBX all computers have microsip softphone with extension 1-5 tested sip calls are working between them.
BT Landline is connected to line port of SPA3102 and an analogue phone is connected to extension 5
in info page of spa3102 SPA config Line 1 is showing registered and PSTN Line is also registered ,
Line 1 is connected using pjSIP and PSTN is connected using CHANsip.
incoming calls are working but no caller ID I have called ID on my package, secondly I cannot dial out, as soon as i dial a number it says all circuits are busy now, please try your call again later.
my settings are show in photos attached. I have changed last 4 digits of my phone for privacy. is Freepbx is SPA3102

Any help is greatly apprecaited

Well you don’t have a caller ID set on the outbound route, so you need to set a caller ID on the extension that is registered to that port on the ATA. In FreePBX.

For incoming, I’m guessing that the SPA’s Caller ID Method is not set for BT’s caller ID format. You can confirm that with SIP debug (seeing the From header without the calling number), or with syslog on the SPA.

I believe that on copper pairs from the CO they use ETSI FSK With PR, but if your landline is delivered over fibre or VDSL, they may use another format, so you may need to experiment.

For outgoing, try setting VoIP Caller Default DP to None or 1. If no luck, at the Asterisk command prompt type
sip set debug on
make a failing outbound call attempt, paste the Asterisk log for the call at and post the link here. If you are too new to post links, just post the last 8 hex characters of the URL.

Hi Adell4444, thanks for your reply, I have tried to add a caller id in outbound route still it says all circuits are busy now please try again later.

Hi Stewart,

Hope you are well, I was hoping to have your reply, I have used exactly the same settings as yourself from this post Dialplan issue - #3 by Stewart1.

My connection is with Talktalk which uses a BT line, my phone is connected directly is the BT master socket. there are two wires coming out of master socket one goes to the phone and second one goes to router which gives internet to router. I have tried to change the regional settings to ETSI FSK with PR but still it does not work for caller ID, actually I have tried every setting in Caller ID method of spa3102 and rang but my extension only displays BT-POTS instead of caller ID.

for outgoing I have tried to set VoIP caller default do to none and 1, still no luck.

here is a log for failing call

I am fairly new in this one so any help in this regard is greatly appreciated. Many Thanks

It’s coming from:


and you have:


However, you don’t have trustrpid in your chan_sip configuration. From is being used for authentication.

I’m not convinced that the device secured against toll fraud.

On the outbound call, Asterisk didn’t even attempt to send it to a trunk, even though there is a valid Outbound Route. Check that Trunk Sequence for Matched Routes has the SPA trunk, the trunk is Enabled and it shows as available in the list of peers.

For incoming, set up syslog on the SPA and see what gets logged at the beginning of an inbound call. If the calling number does appear, do ‘sip set debug on’ at the Asterisk command prompt and see if the number appears in any header. If syslog does not show the number, with luck there will be a useful error message. If not, rig a way to listen on the analogue line to determine the format being used.

You are a genius Stewart, Trunk Sequence didn’t have the SPA trunk as soon as I added it there outbound calls started to work. one less problem now.

Caller ID problem is still there, I have setup syslog on SPA using winshark and dialled a call from my mobile no which starts with +447586274XXX (last 2 digits hidden for privacy reasons). please see the pastebin link below if you can make any sense
its showing call-id 952dac9b-3bca8491, I am not sure what it means.

I have also done sip set debug on Asterisk and dialed a call from my mobile, Caller ID number still does not appear there
Untitled - FreePBX Pastebin.

This is normal, not related to caller ID, and not a problem. The value is an opaque and nominally globally unique value for the call.

The ATA is sending RPID, but not using the incoming one. That’s a problem with the ATA. Until you can get the ATA to include the caller ID in the INVITE, there is nothing you can do a the Asterisk/FreePBX end.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.