"All circuits are busy" after migration


(Patrick Miller) #1

Hey all,

I just migrated our FreePBX server from Upcloud to Digitalocean. Somehow, incoming calls work fine, but outgoing calls give us “all circuits are busy now.”

Trunk settings are the same. We use Flowroute, and the new server registers with it just fine.

Logs when I make a call show:
image

Any idea on where to start?


#2

It appears that the route ‘AMZ Transit Toll Free’ got selected. Is that correct (you were not calling a toll-free number)? In any case, no trunks were offered. Check that the Outbound Route contains the proper list of trunks. If so, then the trunk(s) may appear offline because qualify failed. This may be because your new IP address has not been set as authorized on the Flowroute portal. What does Reports -> Asterisk Info -> Peers show?

If you still have trouble, paste the log at pastebin.freepbx.org and post the link here. Please do not post text as an image (hard to search, can’t copy/paste, etc.)


(Patrick Miller) #3

Thanks for your help. Flowroute claims everything is okay on their end.

Peers shows the following:
Endpoint: <Endpoint/CID…> <State…> <Channels.>
I/OAuth: <AuthId/UserName…>
Aor: <Aor…>
Contact: <Aor/ContactUri…> <Hash…> <RTT(ms)…>
Transport: <TransportId…> <BindAddress…>
Identify: <Identify/Endpoint…>
Match: <criteria…>
Channel: <ChannelId…> <State…> <Time…>
Exten: <DialedExten…> CLCID: <ConnectedLineCID…>
==========================================================================================

Endpoint:  301/301                                              Not in use    0 of inf
InAuth:  301-auth/301
Aor:  301                                              100
Contact:  301/sip:301@67.81.154.207:54847;rinstance= 09afa92d22 Avail        13.905
Contact:  301/sip:301@67.81.154.207:5060;x-ast-orig- 9a51761391 Avail        28.490

Endpoint:  302/302                                              Unavailable   0 of inf
InAuth:  302-auth/302
Aor:  302                                              100

Endpoint:  303/303                                              Unavailable   0 of inf
InAuth:  303-auth/303
Aor:  303                                              100

Endpoint:  304/304                                              Not in use    0 of inf
InAuth:  304-auth/304
Aor:  304                                              100
Contact:  304/sip:304@179.49.44.179:55262;rinstance= 89aad7ad75 Avail       228.308

Endpoint:  316/316                                              Not in use    0 of inf
InAuth:  316-auth/316
Aor:  316                                              100
Contact:  316/sip:316-ecbfb759dff99f87db7627cf982a6a eeee2605ec Avail         9.238

Endpoint:  322/322                                              Unavailable   0 of inf
InAuth:  322-auth/322
Aor:  322                                                1

Endpoint:  399/399                                              Unavailable   0 of inf
InAuth:  399-auth/399
Aor:  399                                                1

Endpoint:  401/401                                              Not in use    0 of inf
InAuth:  401-auth/401
Aor:  401                                              100
Contact:  401/sip:401@67.81.154.207:5060;x-ast-orig- 24f81e7b6c Avail        33.348

Endpoint:  402/402                                              Unavailable   0 of inf
InAuth:  402-auth/402
Aor:  402                                                1

Endpoint:  dpma_endpoint                                        Unavailable   0 of inf

#4

The trunk is not appearing at all (it’s not just offline, it’s missing). Are you sure it’s a pjsip trunk? Does it show as Enabled at Connectivity -> Trunks?

If you still have trouble, post a screenshot of your trunk settings.


(Patrick Miller) #5

I deleted and recreated the trunk using PJSIP but still having the same issue. I followed Flowroute’s instructions as well.

Here’s the current error:

And the trunk settings:


#6

It appears that you don’t have an Outbound Route matching 9179977007 . In your previous log, you called +19179977007, which did match.

You should have a consistent format for dialing numbers. It’s ok to accept multiple formats, but your Outbound Route and/or trunk manipulation rules must convert them to something the trunking provider will accept. Flowroute will accept 19179977007 and +19179977007, but not 9179977007. They assume that all numbers start with the country code (+ is optional). 91 would be India, but there aren’t enough digits following.


(Patrick Miller) #7

Is this something I’d change in dial patterns? I have everything turned on. That is:

Thanks for your help, I do appreciate it.


#8

IMO, turning on all the wizards creates garbage, but it should allow you to dial 19179977007 . If you want 9179977007 to also work, set prepend to 1 for the NXXNXXXXXX pattern. Once you get past this, erase the junk and migrate the patterns from your old system.

And please, do not paste logs as an image. Select the text, hold command and type c to copy, go to pastebin.freepbx.org, click in main window, hold command and type v to paste, post the link here.


(Patrick Miller) #9

Okay I mostly have it working. Only thing is, we have to dial 1 before any normal US number.

Any ideas on what dial pattern to add to avoid this?


(system) closed #10

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.