ALL CIRCUIT BUSY pjsip log


(United States) #1

2020-06-05 17:21:32] VERBOSE[9683][C-00000004] pbx.c: Executing [s@macro-dialout-trunk:32] ExecIf(“PJSIP/204-00000002”, “0?Set(DIAL_TRUNK_OPTIONS=)”) in new stack
[2020-06-05 17:21:32] VERBOSE[9683][C-00000004] pbx.c: Executing [s@macro-dialout-trunk:33] Set(“PJSIP/204-00000002”, “HASH(__SIPHEADERS,Alert-Info)=unset”) in new stack
[2020-06-05 17:21:32] VERBOSE[9683][C-00000004] pbx.c: Executing [s@macro-dialout-trunk:34] Dial(“PJSIP/204-00000002”, “PJSIP/13034640011@F1Systems,300,Tb(func-apply-sipheaders^s^1,(1))M(send-obroute-email^13034640011^3034640011^1^1591399292^^204)”) in new stack
[2020-06-05 17:21:32] ERROR[5959] res_pjsip.c: Endpoint ‘F1Systems’: Could not create dialog to invalid URI ‘F1Systems’. Is endpoint registered and reachable?
[2020-06-05 17:21:32] ERROR[5959] chan_pjsip.c: Failed to create outgoing session to endpoint ‘F1Systems’
[2020-06-05 17:21:32] WARNING[9683][C-00000004] app_dial.c: Unable to create channel of type ‘PJSIP’ (cause 3 - No route to destination)
[2020-06-05 17:21:32] VERBOSE[9683][C-00000004] app_dial.c: No devices or endpoints to dial (technology/resource)

What is going on here?


#2

Before even attempting the call, Asterisk decided that the trunk was unavailable. Registration (if used) may have failed. Otherwise, qualify failed (no reply to OPTIONS requests sent out).

In addition, the Outbound Route did not specify any backup trunks, so the overall call failed.

Earlier (perhaps much earlier) in the log, you should see errors relating to registration failure and/or host unreachable. You can troubleshoot this with pjsip logger or network packet captures.


(United States) #3

I dont see that. In fact it looks like it is “REACHABLE”

[2020-06-05 17:45:26] VERBOSE[15607][C-0000000a] res_agi.c: Launched AGI Script /var/lib/asterisk/agi-bin/sangomacrm.agi
[2020-06-05 17:45:27] VERBOSE[15607][C-0000000a] res_agi.c: <PJSIP/204-00000009>AGI Script sangomacrm.agi completed, returning 0
[2020-06-05 17:45:27] VERBOSE[15607][C-0000000a] pbx.c: Executing [s@crm-hangup:8] Return(“PJSIP/204-00000009”, “”) in new stack
[2020-06-05 17:45:27] VERBOSE[15607][C-0000000a] app_stack.c: Spawn extension (from-internal, h, 1) exited non-zero on ‘PJSIP/204-00000009’
[2020-06-05 17:45:27] VERBOSE[15607][C-0000000a] app_stack.c: PJSIP/204-00000009 Internal Gosub(crm-hangup,s,1) complete GOSUB_RETVAL=
[2020-06-05 17:45:36] VERBOSE[5959] res_pjsip/pjsip_configuration.c: Endpoint F1Systems is now Reachable
[2020-06-05 17:45:36] VERBOSE[5959] res_pjsip/pjsip_options.c: Contact F1Systems/sip:14280612@us-west-or.sip.flowroute.com:5060 is now Reachable. RTT: 58.664 msec
[2020-06-05 17:45:54] VERBOSE[5879] asterisk.c: Remote UNIX connection
[2020-06-05 17:45:54] VERBOSE[15732] asterisk.c: Remote UNIX connection disconnected
[2020-06-05 17:45:54] VERBOSE[5879] asterisk.c: Remote UNIX connection
[2020-06-05 17:45:54] VERBOSE[15738] asterisk.c: Remote UNIX connection disconnected
[2020-06-05 17:45:54] VERBOSE[5879] asterisk.c: Remote UNIX connection
[2020-06-05 17:45:54] VERBOSE[15740] asterisk.c: Remote UNIX connection disconnected
[2020-06-05 17:45:54] VERBOSE[5879] asterisk.c: Remote UNIX connection
[2020-06-05 17:45:54] VERBOSE[15742] asterisk.c: Remote UNIX connection disconnected
[2020-06-05 17:45:57] VERBOSE[5879] asterisk.c: Remote UNIX connection
[2020-06-05 17:45:57] VERBOSE[15938] loader.c: Reloading module ‘res_odbc.so’ (ODBC resource)


(United States) #4

There is not backup trunk. I am not having luck making sense of the logs.


#5

Flowroute supports both registration and IP authentication. If you are using registration, failure to register will cause the trunk to be unavailable, even if it’s ‘reachable’. If using IP auth, the trunk may have appeared to be unreachable at the time of the call attempt and become reachable later.

When you see an ‘is now Reachable’, that means it was previously unreachable.


(United States) #6

I have done both registration and ip auth with Flowroute. Is that a problem?


#7

Doing both on the same account is not at all a problem, but doing both on the same trunk is pretty weird, because a loss of registration will cause outbound calls to fail.

If you don’t have a static IP address, or have multiple internet connections, registration is usually best for incoming, so Flowroute can send calls to the correct address. With static IP, having them send calls directly to the address is more robust; there is no risk of lost registration.

For outgoing from a dynamic IP, you can use user/pass authentication, so an address change won’t block your calls. If you have a static IP or multiple static IPs, you can pre-authorize them on Flowroute’s portal and calls from those addresses will be accepted with no further auth (though the proper tech prefix must still be sent).


(United States) #8

This all was working, btw. I change something.

There is one trunk so, yes, they are both on this same trunk. I have confirmed Tech ID, secret, sip server. I have deleted the outbound route and recreated it to no avail. I am at a loss.


(United States) #9

[2020-06-05 18:16:59] ERROR[5959] res_pjsip_header_funcs.c: No headers had been previously added to this session.

Does this have baring?


#10

Sorry, I have not seen this error before and have no idea what it means. If the trunk is showing as online, pjsip logger should show an outgoing INVITE and the response will likely show what’s wrong. If it’s offline, pjsip logger can show REGISTER (if applicable) and OPTIONS requests and their responses.


(United States) #11

Solution: Enabling SIP Credentials at Flowroute allowed outbound calling, no more ACB message.

In reviewing security settings it was suggested to disable SIP Credentials if using a static IP host, when I did that we lost outbound calling. Enabled it and outbound started to work but we lost inbound!

As I said, I had mistakenly changed the SIP port in both my PBX and at Flowroute in Inbound Routes. Though I had changed the SIP port back to 5060 to it required deleting and adding the route.

All is well. Thanks.


#12

This usually means that the public IP address from which you sent the call is not listed in Allowed Outbound IPs on Flowroute.


(United States) #13

We had changed the SIP port then changed it back to 5060. The Outbound Route still used address:xxxxx instead of address:5060. Deleted the route and recreated it, all is well. Thanks.


(system) closed #14

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.