Alerts ringtones still not working

Freepbx Distro / Asterisk 13.23.1

follow up on closed issue Paging and intercomm Broken since module updates

Phones are D40’s and on Firmware 2.8.0

The issue persists. Core is now 13.0.131.

I can’t roll back to a usable core anymore from the web gui as it only allows rollback to 13.0.126

what is the permanent fix for this? Is it a phone issue, freePBX issue or Asterisk issue?

Just got this working today on our digium phones and have tested it after applying the latest module updates and digium firmware.

First, you must edit the digium_phones_alerts database table in order to get the new alert info settings to work on digium phones as scristopher7 found in the following: Digium phones paging/intercom stopped working - found fix

Once that’s applied, the new alert info format as mdavenport noted in response to my post with <>\;info=CUSTOMALERTHERE will apply. The way I understand it is scristopher7 found there’s a default character limit that’s being violated when you append the http://... in front of the custom alert. I believe he states the default is 30 characters and when you add in the new requirements you only have 5 characters left for a custom alert. Either reduce the alert to fit the default 30 character limit or increase the database limit.

For Digium phones, the preconfigured alert-info header i think a lot of us use for paging/intercom requires the alert info string of ring-answer, so you must increase the database size for this.

Hope this helps.

Sorry about the wording in my post, its a little off. What I meant to say was that I had to edit the column in the database table to change the character limit value to something higher than 30. The issue appears to be that digium phones are setup to strip anything in <> which used to be just <Alert Info: foo>, since <>; info=CUSTOMINFO is the new value it was causing issues with the alert. The problem now is that the new alert info is longer than 30 characters, so if you need to update the column to more than 30 (I set mine to 100) its pretty easy from the cli:

Issue fwconsole m which will drop you into the mariadb/mysql cli connecting to the asterisk database:
[[email protected] ~]# fwconsole m

Increase the length of the column alertinfo in the digium_phones_alerts table as needed (change 100 to whatever value you need):
MariaDB [asterisk]> ALTER TABLE digium_phones_alerts MODIFY alertinfo VARCHAR(100);

That should be it. I just wish there was a ‘official’ fix for this.

2_7_4 and 1_9_7 forward, they don’t strip anything anywhere. Previously, it was the leading < that was causing trouble. Now, if what’s sent in the header is:


then the phone’s actual config file needs to include that.

Ahh ok good to know. In the digium phones module I’m using what I saw in the asterisk cli for the alert info which is <>\;info=ring-answer and seems to be working fine now. Not sure if you are saying to just use;info=foo or if the formatting on the page is stripping off the <> marks, either way I’m just happy its working now :wink:

Discourse was stripping it. I have edited it.

Ok that makes sense! By any chance will we see a update in the future for the digium phones module that lets you add alert info longer than 30 characters?

It’d be nice if the <>\;info= was already hard coded in the background so that the freepbx ui alert info entry is simplified.

A) awesome responses guys! thanks.
2) So is this fixed in the latest firmware/core module or do I still need to edit the database column size?

assuming your alert info is over 30 characters (and your using the digium phones module with alert info stored in the db) you’d have to change the column size still, I’m really hoping we see an update that changes the limit or makes it simpler like @awolf13 mentioned.

sounds good. Currently upgrading to FreePBX Distro 14 on this systems so we’ll see after that process is finished. Phones are already on latest firmware.

Nice work scristopher7!!! :muscle:

It appears that the digium phones module is no longer being maintained and is being merged into enpoint manager, so I’m guessing we won’t see an update for the digium phones module. I can’t say I’m really thrilled because I like the digium phones module much more than EPM…

Exactly, I can use EPM but I much prefer the DMPA module. Sooo much easier in my mind to work with.

Ditto. I’ve looked at EPM in preparation, but from what I’ve seen (could be missing something) there’s not the same amount of configuration available as there is in the DPMA module. The EPM templates are nice for bulk changes, but all the DPMA options are not there.

ok, so updated to FreePBX 14. Upgraded the phone firmware to 2.8.0. Modified the database table field and still not getting proper ring tones for alerts…

Are you using a custom alert for external calls or internal paging or both? Might be best to start with an internal auto answer just for testing purposes. Be sure the alert field is completed as previously indicated:Capture

Alert Name: enter anything here
Alert Info: <>\;info=ring-answer
Ringing Type: ring-answer
Ringtone: whatever

Once configured, be sure to apply it to a couple of phones and reconfigure them.

1 Like

still not working…

have the alert created as specified
have it assigned to phone
have it assigned to inbound router AND ringgroup

from asterisk logs:
[2019-04-15 21:39:18] VERBOSE[6786][C-00000015] pbx.c: Executing [[email protected]:5] While(“SIP/212-00000042”, “1”) in new stack
[2019-04-15 21:39:18] VERBOSE[6786][C-00000015] pbx.c: Executing [[email protected]:6] Set(“SIP/212-00000042”, “sipheader=alertest”) in new stack
[2019-04-15 21:39:18] VERBOSE[6786][C-00000015] pbx.c: Executing [[email protected]:7] ExecIf(“SIP/212-00000042”, “0?SIPRemoveHeader(Alert-Info:)”) in new stack
[2019-04-15 21:39:18] VERBOSE[6786][C-00000015] pbx.c: Executing [[email protected]:8] ExecIf(“SIP/212-00000042”, “1?Set(sipheader=<>;info=alertest)”) in new stack
[2019-04-15 21:39:18] VERBOSE[6786][C-00000015] pbx.c: Executing [[email protected]:9] ExecIf(“SIP/212-00000042”, “1?SIPAddHeader(Alert-Info:<>;info=alertest)”) in new stack


  1. be sure to include the \ between the url and the ;info
  2. the inbound route and ring group alert should just be the alerttest and not all the other jargon.

I also updated my CORE module and FreePBX Framework to the latest on the EDGE track. It seemed there were a few potential fixes i was looking for in the changelogs, but cannot remember what they were off the top of my head.

A stab in the dark, but one other thing I was experiencing was I had updated the EPM before they released a fix that stopped writing changes to a particular Digium file which was throwing an error saying something to the effect that I was running a modified Digium phone file. This was causing all of my DPMA reconfigurations to not apply. I noticed this when i checked a phone’s firmware on the physical device and it was not reflecting what I had set in the DPMA. In order to solve this, I temporarily uninstalled the Phone Apps and EPM modules, and ensured I was using an unmodified DPMA then sent a reconfiguration to the phones and all was working as intended.

upgrading to edge now…

may have bigger issues. after the upgrade to 14 I have no audio on calls in either direction… gotta chase that down too

audio issue fixed, sip settings local network setting.

alerts still not working at all. paging not working either. Upgraded all modules to edge version. rebooted phones. pushed re-config from DPMA module. Here’s my current config