Alert Info broken + changed to (Sangoma) Ring X

Not sure when this happened but everywhere we had an alert info field set to anything other than blank it seems to be set to (Sangoma) Ring 3. Obviously this doesn’t work for the Yealinks. Havent tried other models but I assume it’ll be the same result.

Also, some of the Yealink rings don’t seem to work correctly. Has the syntax changed? Not sure if this is a Yealink firmware issue or something freepbx-related. through 4 seem to work OK and dr8 seems to be the regular ringer.

dr5 rings one short ring, then a long silence (maybe 10 seconds?), another short ring, and then another long silence.

dr6 is just silent the entire time.

dr7 does one short ring and then silence for the remainder of the timer (I only tested up to 15 seconds).

The PBX I’m testing with is still on 10.13.66-20 but all the modules were updated to the latest yesterday to mess with the CRM module. I tested this by setting the Alert Info in various Ring Groups (module level and I’m testing on an old t22.

You can change this to whatever you want. As for FreePBX changing it, that was not intentional and I haven’t seen any reports of it happening to anyone.

The top one is the one I changed manually. The bottom one is what it changed to at some point. These are both DIDs on the same PBX.