Agent restrictions in queue not working


(Artsiom82) #1

Hell everyone. Is it a bug?
Agent restrictions set to “ring as dialed”
in queue agent i have and agent with follow me to external phone
if ringing to agent directly all ok,
but if ringing through queue nothing happens
help me pls
Current Asterisk Version: 16.6.2
FreePBX 15.0.16.52


(Itzik) #2

Can you post a screenshot of the queue settings?
Also please provide a call trace using a pastebin link

Instructions here: https://wiki.freepbx.org/display/SUP/Providing+Great+Debug#ProvidingGreatDebug-AsteriskLogs-PartII


(Artsiom82) #3


(Itzik) #4

Please post two PASTEBIN links with two call traces, one to the queue and one to that same extension.


(Artsiom82) #5

sorry %)
queue https://pastebin.freepbx.org/view/85c77a59
same extension https://pastebin.freepbx.org/view/7c9005b4


(Itzik) #6

334 is not a member of the queue, it wasn’t called in the queue. In fact, you have no members in the queue at all…

Can you post a screenshot on your queue agents tab?

Also, whats the output of:

asterisk -x"queue show 10001"

(Artsiom82) #7


[root@freepbx ~]# asterisk -x"queue show 10001"
10001 has 0 calls (max unlimited) in ‘ringall’ strategy (0s holdtime, 0s talktime), W:0, C:0, A:2, SL:0.0%, SL2:100.0% within 60s
Members:
334 (Local/334@from-queue/n from hint:334@ext-local) (ringinuse enabled) (Unavailable) has taken no calls yet
No Callers


(Itzik) #8

Seems like 334 is an extension that has a device, and for some reason the queue won’t call that extension if it is unavailable.

You can try to create a virtual extension with a FollowMe and add that to the queue.
And/or under the extension’s advanced tab, set Queue State Detection = Ignore state


(Artsiom82) #9

yes but it should, because “Agent Restrictions” set to “call ad dialed” in that case, as i inderstand “follow me” shouldn`t be ignored

“And/or under the extension’s advanced tab, set Queue State Detection = Ignore state” make my day thanks