FreePBX | Register | Issues | Wiki | Portal | Support

Agent can't Unpause after AutoPause if Queue caller is waiting


(Dsivoip) #21

Sorvani, thanks for the code location reference.

I don’t think reversing 1 and 2 would do it, as the instruction for 2 is dependent upon the PAUSE_STATE set during 1 to determine which message to play.

Next is to figure out what to modify, and where to put it to trigger an appropriate response whenever the toggle command has been initiated by a queue agent that was paused.

I can see the referenced “/etc/asterisk/extensions_additional.conf” file is one that is protected from editing. I’ve also noted how in the “app-queue-pause-toggle-custom” section of that file there is an “include” statement, this would be the address where a modification could be inserted. At the top of this file it shows “globals_custom.conf” as an included location in which I could place a modified [app-queue-pause-toggle-custom] to run from the above-mentioned include line in [app-queue-pause-toggle].

With this info I should be able to ferret out how to rewrite the existing instruction to prevent it from doubling-down and pausing the agent again. Then add a GoTo (or asterisk equivalent) pointing to the following [app-all-queue-pause-toggle] section, skipping the [app-queue-pause-toggle] instructions that exist after the “include” line.

A little trial and error should turn up the right set of modifications to make this work.

If successful, I’ll post up the script that solves it.

Thanks!


(Jared Busch) #22

That’s not going to work like you expect.

To override a built in function, you need to use /etc/asterisk/extensions_override_freepbx.conf

You can very easily test it by copying the code and switching the two lines.

Than hangup happens fractions of a second after the status change instead of multiple seconds later after the agent hears “agent unpaused”

Best solution? Not likely. But I bet it resolves your issue until a dev familiar with the queue code and queue auto pause code has time to look at things.


(Dsivoip) #23

Any idea where they hide the script associated with the “Queues/Skip Busy Agents” feature?


(Dsivoip) #24

Walter at Sangoma has moved the Bug Report from Closed to Triage, after we worked through the issue together.

He agreed that both the software and documentation need attention.

We were able to find a work-around that fixed the problem for my application, as follows:

In the Queue module, General Settings tab, for:

  • Agent Restrictions - select Extensions Only
  • Skip Busy Agents - select Yes + (ringinuse=no)

This gets around the software auto-pausing the Agent when toggling deactivate Pause while a caller is waiting in a Queue.

Problem solved, sort of.


(Lorne Gaetz) #25

Knowing this, I assume you had FMFM enabled for the affected extensions, possibly with a ring strategy of *prime or some other less common ring strategy. Something that would have prevented the extension from ringing but not stopped the queue from sending calls, hence the auto pause.


(Dsivoip) #26

FindMe/FollowMe is disabled on all extensions.

Extension/FMFM/Ring Strategy is ringallv2-prim (presumably default as this is a setting I haven’t touched) but FMFM is not enabled, so this should make no difference, correct?

Queue Ring Strategy is set to rrordered on one queue, and rrmemory on the other. I don’t see a *prime choice in the Ring Strategy drop-down menu for either Queue.

The original post covers more of the Queue setup, and I edited that post this morning to correct a typo and include the setting for Skip Busy Agent that was used to make the issue occur.


(system) closed #27

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.