After upgrading from 13 to 15 all of my Endpoint manager setting are gone


#1

Hello,
After upgrading Freepbx Distro from 13 to 14 to 15 I have found that all of our settings in the endpoint manager are gone. I have backups from before the upgrades but if I restore to a test VM I can’t see the settings because I don’t have a license for the test system. any ideas on how I might be able to restor this data. I had a lot of extensions setup with the MAC addresses as well as some baseline customizations.

Rodney


(TheWebMachine Networks (Sangoma Software Development Partner)) #2

Perhaps you could launch a clean v15 instance and then use the new Backup/Restore module to restore your v13 backup. v15 now supports restoring backups made on previous versions of FreePBX, allowing a safer “migration” style pathway to upgrading.


#3

I have been able to restore the 13 backup to my secondary version 15 server but now I would like to know how to backup just the Endpoint Manager settings to restore to my Primary server. I have tried to do this using the Backup and restore and selected only the Endpoint Module but when I restore it still no settings.


#4

This is the message I get from the restore

Running with: /usr/local/sbin/fwconsole backup --restore=’/var/spool/asterisk/backup/uploads/20200130-150908-1580422148-15.0.16.42-2005282695.tar.gz’ --transaction=‘5b68bbf0-3845-48df-805a-c5f6db1fa999’
Determining backup file type…type is current
Starting restore job with file: /var/spool/asterisk/backup/uploads/20200130-150908-1580422148-15.0.16.42-2005282695.tar.gz
Extracting Backup
Extracting backup…
Processing endpoint
The module endpoint does not seem to support restores.

Restore processing for modules are finished successfully
Reloading… DONE
Running Post Restore Hooks… Please note that hook will restart httpd service so please refresh your page (using new ports)
Running Post Restore Hooks DONE
Finished
Restore completed successfully


(Kapil Gupta) #5

Hi @chuckrick please make sure you are using latest edge release of endpoint manager i.e. v15.0.24.36. Thanks.


#6

Set Module Admin to Edge mode is set to yes in the Advanced settings but in Module admin it shows Endpoint manager version 15.0.16.21 Enabled and up to date.


(Kapil Gupta) #7

Hi @chuckrick 15.0.16.21 seems quite old, are you sure you have “active” license to get the updates.


(Lorne Gaetz) #8
[root@58448910 ~]# fwconsole ma list | grep endpoint
| endpoint             | 15.0.24.32 |

https://wiki.freepbx.org/display/FPAS/How+to+Renew+FreePBX+Commercial+Modules+Maintenance


#9

I did the renewal but I am still getting

[root@freepbx ~]# fwconsole ma list | grep endpoint
| endpoint | 15.0.16.21 | Enabled | Commercial |


(Lorne Gaetz) #10

After making changes in the portal to your licensing, they have to be synced to the PBX:

fwconsole sa update

After that, upgrade should work but it’s possible that the previous version was cached, so you can upgrade directly using:

fwconsole ma downloadinstall endpoint --tag 15.0.24.32

#11

Thank you for the help. This did work but I did need to run the fwconsole ma downloadinstall endpoint --tag 15.0.24.32.


(Edwin) #12

On Saturday I did a new instance install of 15, activated the existing deployment then restored the 14 backup. Everything went perfect! Or so I thought…

This morning all my Sangoma S500 endpoints are at default with just Account 1 & 2 working. I can Save, Rebuild Config & Update phones from the EPM UCP Custom entries screen, the phones attempt re-provision but remain at default nonetheless.

@lgaetz I followed your suggestions above to no avail. At least our calls are working but no BLF’s or any of the settings are being pulled from the phones. Typical Monday morning restricts my time, any pointers would be appreciated. Thank you.

EDIT: Problem sorted with re-registering phones following factory reset (after hours). Probably missed that somewhere in the Wiki.


(system) closed #13

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.