After PBX Restore modules: Disabled; Pending upgrade to

After a restore from one PBX config to Anaother PBX, I get this notice on many modules:
-Disabled; Pending upgrade to …

This is the result of different module versions between the pbxs.

Offcourse I can click them all to update and enable, but can this be done easier such as a command from cli?

module_admin upgradeall does not work, tried many other settings, but no easy way found.

Any help would be welcome.

amportal a ma installlocal

Probably upgradeall

Thanks for the answers but I tried buth solutions above, and none worked for me.
Any ideas more?

I think you need to download all with the force flag

I have run into this before, it is very important to only restore on same versions. It can take hours of tinkering to get it right. Essentially now you are trying to downgrade the FreePBX. You made it worse by backup up webroot.

Also consider it still may not work as database schema changes between updates.

I would almost download the tarball of the version you are trying to restore from and do an install_amp. It will detect the existing installation and simply copy the modules. Make sure you do an rm -fr /var/www/html/admin/* prior to running install_amp

Make sure you have good backup before doing any of this.

Things that are going to snag you.

AMPDB not restored
Backup profiles stuck and using 100% CPU (see top)
Asterisk not starting due to presence of cel config files

Hi Skyking,
Thats a great answer. Someone who has experienced the same problem.
Finally I think it is the most simple solution to update both PBXs to the latest modules before backup>restore.
This will take less time and complexability for migration.

Both FreePBX systems should be the same version.