After move/upgrade all calls to extensions go to unavailable/voicemail


#1

I got this system which was using FreePBX 13. I did a backup of FreePBX, and moved it over to FreePBX 15 (restored). I shut the old system down,then rebooted the new one using the same public IP address as the old one.

Now after the new system is up, every single call to any extension is going to voicemail. I have both chan_sip and chan_pjsip extensions, and even some extensions connecting via OpenVPN client on the telephone, and all are having the exact same issue.

It is using Asterisk 16.x.x, but then tried downgrading to asterisk 13 for a bit. Still getting same result as before.

Outbound calls functioning as expected.

Here is a paste of a test call from extension 299 to 296

Also interesting is looking at sngrep I see the following

2020/10/16 21:27:00.834789 65.49.22.237:5060 -> 189.156.86.176:38416
SIP/2.0 401 Unauthorized
Via: SIP/2.0/UDP 192.168.1.62:38416;branch=z9hG4bK-d87543-7e58802e8c72c870-1–d87543-;received=189.156.86.176;rport=38416
From: "299"sip:299@65.49.22.237;tag=fa004066
To: "299"sip:299@65.49.22.237;tag=as4a10d0c1
Call-ID: dc1fee43d1032143MzQ4MzcyN2E3MDZhYjJmOTQyMjlkNjk0MDAyZDUxYjI.
CSeq: 95 REGISTER
Server: FPBX-15.0.16.75(16.13.0)
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLISH, MESSAGE
Supported: replaces, timer
WWW-Authenticate: Digest algorithm=MD5, realm=“asterisk”, nonce=“10fbafe8”
Content-Length: 0

Anyone got some ideas on this?

Thanks


(Dirk2358) #2

Seems your extensions aren’t registered (and that’s why inbound calls go to VM) - therefore you should check why they can’t register. Maybe wrong passwords?


#3

Problem is they are registered, and that is why outbound calls are functioning as I mentioned. I can watch the Asterisk CLI and see them registering, and if I exit out of the softphone I am using, see it unreregister


#4

That is not quite true, though unrelated to your problem. Asterisk does not require registration for outgoing calls; it authenticates each INVITE that it receives.

This problem does not appear to be related to SIP at all, but appears that the database relating extensions to devices is corrupted:

Starting on line 279:

    -- Executing [dstring@macro-dial-one:2] Set("SIP/299-00000014", "DEVICES=") in new stack
    -- Executing [dstring@macro-dial-one:3] ExecIf("SIP/299-00000014", "1?Return()") in new stack
    -- Executing [s@macro-dial-one:29] GotoIf("SIP/299-00000014", "1?nodial") in new stack
    -- Goto (macro-dial-one,s,61)
    -- Executing [s@macro-dial-one:61] NoOp("SIP/299-00000014", "") in new stack
    -- Executing [s@macro-dial-one:62] ExecIf("SIP/299-00000014", "1?Set(DIALSTATUS=NOANSWER)") in new stack
    -- Executing [s@macro-dial-one:63] NoOp("SIP/299-00000014", "Returned from dial-one with nothing to call and DIALSTATUS: NOANSWER") in new stack

Are you using device and user mode?
As a test, try deleting an extension and recreating it (be careful to use the same secret), then see if it can receive calls. Or, create a new extension for this test.

BTW, when you paste logs or other text data, please use pastebin.freepbx.org . If you use an alternative paste service, please confirm that your paste expiration is set to never. Otherwise, future readers who may be helped by the thread will be unable to follow along.


(Lorne Gaetz) #5

If there is Asterisk DB corruption, this command will resolve:

fwconsole util resetastdb

#6

That was it: corrupt database. Thanks very much for the responses and helping me get that resolved.