After module update, no top menu

I did a module update today (bad me I can’t remember which ones…) but now I have no top menu in my admin area. I have tried fwconsole restart, and I have restarted the httpd service. Not sure what else to try

Can you take a picture of what you mean

I was looking for a way to do that when i posted, but couldn’t find it. (sorry, I’m new to forum). I think I attached it to this reply.

I registered just to say “Me too”.
Upgraded Freepbx 13 to 14 when this started happening.

I did try several things to restore:

  • Under advanced settings the CSS en JS settings (no help)
  • Reinstalled all modules with fwconsole (no help)
  • Reboot server (no help)
  • Searched logfiles for any errors (none found. no help)
  • Looked at the webbrowser console for errors (none. no help)
  • Looked at the html. The whole menu part is missing. Verified the html with another working upgrade.
  • Tried all module pages by using the addressbar. All pages work. eg http:// myserver/admin/config.php?display=advancedsettings

PS. I am using a Debian (jessie) server with no special Digium modules.

So totally lost here.

fwconsole ma upgrade framework


Thanks for your message but thats dlready done. (no help)
fwconsole ma upgradeall (no help)

fwconsole ma list | grep framework

11 posts were merged into an existing topic: GUI Broken after last nigth 01/04/2019 Modules Updates

But today there was an upate available to
This update FIXED the missing menubar.

I am a happy camper again.
Thanx for the responses.

When I originally asked the version that’s because @pakenvs and I worked on a fix and published it. You were probably cached at the moment you checked.

At the moment I checked I also had Module Caching (in advaced settings) turned off.
I should have seen that update but did not.

Thanx Andrew and @pakenvs

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.