After latest upgrade, cannot get to FreePBX GUI - (Again)

Returns an error… In the browser window…

“no direct script access allowed” <<< referred from…

Using latest beta version, did FreePBX Module Update >> 28th Dec 2011 >> Rebooted, now cannot get into GUI. Returning web browser error - although the system appears to function - Just no GUI!

Any assistance would be appreciated. Thanks…

ZEANE - [email protected]

I just installed the freepbx distro but I can not login to the PBX administrator option. Same message, “no direct script access allowed”. In the address bar it shows http://myipaddress/admin/config.php

I checked some system logs but no useful messages.

Any help is more than welcome.

Best Regards

This was a bug that with an older version of the FreePBX 2.10beta and was fixed in a new framework we pushed out yesterday. If you have ssh access to your boxes, go to /var/lib/asterisk/bin/ and run ./module_admin download framework and ./module_admin install framework.

If you still have issues please let me know.

Thank you very much - managed to get back into the GUI and upgraded modules - Solved - AWESOME!!!

Happy new year to everybody-

I tested GameGamer43 suggestion but still no luck, I am still receiving the same message:

No direct script access allowed

I have not been able to login to the “pbx administrator” screen since I installed the freepbx distro.

Any help is greatly appreciated.

Best Regards

Something must wrong I received the email message that there some updates available:

UPDATE NOTICE: There are 2 modules available for online upgrades
framework 2.10.0beta3.2 (current: 2.10.0beta2.3)

Is it possible that I am downloading and installing the same framework over and over?

Best Regards

Just to be sure perform the upgrade from the command line, this is what the GUI is doing behind the scenes.

cd /var/lib/asterisk/bin
./module_admin download framework
./module_admin install framework
./module_admin reload

You can see all the module_admin commands with ./module_admin --help


Thank you very much for your suggestion.

This is what I did:

./module_admin list | more


framework 2.10.0beta2.3 Disabled;


./module_admin enable framework

Once again:
./module_admin list | more

framework 2.10.0beta2.3 Disabled; Pending upgrade to 2.10.0beta3.2

./module_admin upgrade framework

And that last command solved the problem. I was able to login to the GUI.

Once again, thank you very much for your support.

Best Regards

when I check my list

configedit 1.0 Enabled
core 2.10.0beta3.0 Disabled; Pending upgrade to
customappsreg Disabled; Pending upgrade to
customcontexts Enabled
customerdb Enabled
dahdiconfig Enabled
dashboard Disabled; Pending upgrade to
daynight Enabled
dictate Enabled
directory Enabled
disa Enabled
donotdisturb Enabled
dundicheck Enabled
endpointman Enabled
enumplus 0.2.3 Enabled
extensionsettings Enabled
fax Enabled
featurecodeadmin Disabled; Pending upgrade to
findmefollow Enabled

[email protected]:/var/lib/asterisk/bin $ ./module_admin enable framework


No direct script access [email protected]:/var/lib/asterisk/bin $

Thanks for any suggestions

After a fail upgrade from the GUI

I did Upgrading to the 2.10 Beta/RC
Which restores part of the GUI…
But still fail to upgrade the framework

[[email protected] bin]# ./module_admin upgrade framework
Downloading 2564592 of 2564592 (100%)

Module framework successfully downloaded
installing files to /var/www/html…done
installing files to /var/lib/asterisk/bin…done
installing files to /var/lib/asterisk/agi-bin…done
Checking for upgrades…1 found
Upgrading to 2.10.0beta3…
-> Running PHP script /var/www/html/admin/modules/framework/upgrades//2.10.0beta3/migration.php
Trying to remove dir /var/www/html/admin/cdr…Not Required
PHP Fatal error: Call to undefined method DB_Error::getRow() in /var/www/html/admin/modules/framework/upgrades/2.10.0beta3/migration.php on line 49

Thanks for your help.

looks like I didn’t make sure that the resulting db handled was a proper handle. However if that failed then your CDR db will not have been migrated but everything else should have been done right.

It uses the creds out of cdr_mysql.conf to open that up so you may want to check if that is right.

There’s a new framework but that migration will not be run again unless you either your install_amp with force-version or manually go into the db and tell FreePBX you are on an older version of FreePBX so the migration is run again. (The former is much easier).

The new framework version worked great!
I did not need any of the old CDR so no worries there!


[email protected]:/usr/src/freepbx $ ./install_amp -f
Checking for PEAR DB…OK
Checking for PEAR Console::Getopt…OK
Console_Getopt: unrecognized option – f
[email protected]:/usr/src/freepbx $

any other suggestions

core 2.10.0beta3.0 Disabled; Pending upgrade to

and I get No direct script access allowed

on the website,

I am also getting the “No direct script access aloowed” error in the admin panel. I tried to follow the framework download/upgrade and got following message. Any help in this regard is greatly appreciated.

I am running latest beta versionn

[[email protected] bin]# pwd
[[email protected] bin]# ./module_admin download framework
The following error(s) occured:

  • Module not found in repository
    [[email protected] bin]# ./module_admin upgrade framework
    The following error(s) occured:
  • Module not found in repository
    [[email protected] bin]#

i an receiving error that says i need help please i need to get operational

my email is [email protected]

when i loging to the gui i see this message bellow

areminder Copyright 2011 by Schmoozecom, Inc., All rights reserved By installing, copying, downloading, distributing, inspecting or using the materials provided herewith, you agree to all of the terms of use as outlined in our End User Agreement which can be found and reviewed at built Tue, 22 Nov 2011 20:07:16 +0000 (1321992436) @r15170

just like that

gives the following error

[email protected]:/var/lib/asterisk/bin $ ./module_admin install framework

No direct script access [email protected]:/var/lib/asterisk/bin $

as always any help appreciated

jvaldez: can you please provide more information, such as any errors, versions, any upgrades run?

rwilliams: what version are you using? Also have you attempted to download framework before running install?


I did a >mistake< during upgrade, as I was not able to upgrade Asterisk 1.6 to 1.8 (Upgrade issues of yum).

So I decided to do:

remove asterisk16 asterisk16-core
ts run


install asterisk18-core asterisk18
ts run

which was not really smart, as it removed freepbx all together

Before, I upgraded all the modules of FreePBX to 2.10 (latest) (was 2.9 before)

Well, this message appears in many PHP files though …

What I found while accessing the conifg.php, is that the error happens somewhere in “// add module sections to $fpbx_menu” section of the code …

There, the last module I see to get parsed is “backup”.
If I “disable” that module by renaming the “”, I end up in fw_fop …
If I “disable” that one, I get to the screen, but it looks the old way. So I guess my problem is not related to anything here then, but due to my “freepbx” package added through yum (old) but the db believes it is at 2.10 …

So, next, I try to remove and re-install modules through module_admin

But not now, something for tomorrow

BTW: will remove module also remove the DB config?

Best regards