AEX2400 echo cancellation firmware not loading

Just installed FreePBX 1.88.210.57-1 64Bit Beta Distro. It appears the echo cancellation firmware is not loading for my AEX2400 card. Any ideas on what to do to fix this?

wctdm24xxp 0000:07:08.0: Port 1: Installed – AUTO FXO (FCC mode)
wctdm24xxp 0000:07:08.0: Port 2: Installed – AUTO FXO (FCC mode)
wctdm24xxp 0000:07:08.0: Port 3: Installed – AUTO FXO (FCC mode)
wctdm24xxp 0000:07:08.0: Port 4: Installed – AUTO FXO (FCC mode)
wctdm24xxp 0000:07:08.0: Port 5: Installed – AUTO FXO (FCC mode)
wctdm24xxp 0000:07:08.0: Port 6: Installed – AUTO FXO (FCC mode)
wctdm24xxp 0000:07:08.0: Port 7: Installed – AUTO FXO (FCC mode)
eth0: no IPv6 routers present
wctdm24xxp 0000:07:08.0: Port 8: Installed – AUTO FXO (FCC mode)
wctdm24xxp 0000:07:08.0: Port 9: Not installed
wctdm24xxp 0000:07:08.0: Port 10: Not installed
wctdm24xxp 0000:07:08.0: Port 11: Not installed
wctdm24xxp 0000:07:08.0: Port 12: Not installed
wctdm24xxp 0000:07:08.0: Port 13: Installed – AUTO FXS/DPO
wctdm24xxp 0000:07:08.0: Port 14: Installed – AUTO FXS/DPO
wctdm24xxp 0000:07:08.0: Port 15: Installed – AUTO FXS/DPO
wctdm24xxp 0000:07:08.0: Port 16: Installed – AUTO FXS/DPO
wctdm24xxp 0000:07:08.0: Port 17: Installed – AUTO FXS/DPO
wctdm24xxp 0000:07:08.0: Port 18: Installed – AUTO FXS/DPO
wctdm24xxp 0000:07:08.0: Port 19: Installed – AUTO FXS/DPO
wctdm24xxp 0000:07:08.0: Port 20: Installed – AUTO FXS/DPO
wctdm24xxp 0000:07:08.0: Port 21: Not installed
wctdm24xxp 0000:07:08.0: Port 22: Not installed
wctdm24xxp 0000:07:08.0: Port 23: Not installed
wctdm24xxp 0000:07:08.0: Port 24: Not installed
wctdm24xxp 0000:07:08.0: Failed to load the firmware.
wctdm24xxp 0000:07:08.0: Found a Wildcard TDM: Wildcard AEX2400 (0 BRI spans, 16 analog channels)
dahdi_transcode: Loaded.
INFO-xpp: revision Unknown MAX_XPDS=64 (8*8)
INFO-xpp: FEATURE: without BRISTUFF support
INFO-xpp: FEATURE: with PROTOCOL_DEBUG
INFO-xpp: FEATURE: with sync_tick() from DAHDI
INFO-xpp_usb: revision Unknown

Apparently the proper version of DAHDI is not included with the distro for the Digium cards. You have to manually upgrade DAHDI from the Digium site. All is well now.

What version of DAHDI did you upgrade to

dahdi-linux-complete-2.6.0+2.6.0 - I don’t know the specifics but apparently Digium does not supply the firmware for the echo cancellation module to anyone perhaps because of licensing reasons. I don’t remember what they told me. But when you download DAHDI directly from Digium you get the proper firmware.