Advanced Settings - Uneditable

I just wanted to make you aware that the settings on the Advanced Settings page cannot be changed. I just upgraded to the beta yesterday, and I don’t recall seeing the Advanced Settings page in 2.8… therefore I believe it may be a bug on your end? However, maybe its a chmod issue on my end?


check the notification panel to see if there is an error telling you what you need to do.

In order to be able to edit them, FreePBX needs write access to /etc/amportal.conf.

If it does not have write access then the settings will be readonly until you give it write access. You can do that by simply running “amportal chown” from the Linux command line. (or “amportal restart” or any other amportal command). This is normally done on most FreePBX distributions eventually, at boot or other times which will rectify the issue.

Hmm… I ran amportal chown and amportal restart. Both were successful, but I still can’t edit the advanced settings. It’s not a big deal though. If I need to edit them I will just go into the amportal.conf file. Thanks!


it is actually a big deal in that we’d like to understand if there are further issues going on. FreePBX 2.9 has moved all settings to the Advanced Settings page and does not use amportal.conf anymore.

However, in order to deal with the transition, it runs in a crippled mode if it can’t write to amportal.conf. The reason it needs to write to that file is to update it with changes that you make in order to allow other applications that used to depend on the same amportal.conf file to continue to work until they have time to migrate. Eventually it will go away completely.

The reason you have to run amportal is that amportal is run as user root and as such, it’s our opportunity to update your system and thus the needed write permissions to amportal.conf.

We also update the dashboard with an error if amportal.conf is not writeable to let you know you need to rectify the problem. So we’d like to understand if there are mechanisms that are broken or if there are simply usability issues such as the settings in Advanced Settings that are readonly and need further overriding in order to write to them.

Ok. There are no error mesages on the dashboard. I don’t currently have the hardware necessary to test my machine so I can’t say if everything is working properly. Everything seems to be editable except for the advanced settings. Im willing to help you in anyway I can so let me know what you would like me to do. This was a fresh install of Asterisk Now a couple of days ago. Since then ive upgraded to the latest version of FreePBX and Asterisk 1.8. After installing the freepbx beta last night, advanced options was one of the first things I tried. So, I can assure you I didn’t screw anything up in the meantime on my end. I also know its not a bug associated with asterisk 1.8 because when I first tried the advanced settings I was running asterisk 1.6.


Also, no settings will update for me on that page. When I hit the green checkmark nothing happens. When I refresh the page they revert back to the original settings.

for starters, go hit “Apply Configuration Changes” and then check your amportal.conf file, did it get auto-generated? (Should be some obvious comments on the top if so).

If not, then we can’t write to it and something odd is going on.

However, if you are getting the green check boxes then it means it thinks you should be able to update them. Anything strange in your environment like a web proxy or anything like that?


go update your modules, I just added some logging to Advanced Settings when you make a change so you will be able to see the updates in your log.

Of course, if not already enabled, you need to use Advanced Settings to enable logging and where to send it:-)

So if worse comes to worse and you are still having problems, I can tell you where to do that directly in the database so we can see if the ajax calls are hitting your server to do these updates.

I got it figured out! I’ve been using Internet Explorer 8.0 on a Windows XP SP3 machine. It wouldn’t let me click the green check button. After you told me I should click “Apply Configuration Changes”, it dawned on me that I’ve never noticed it popup after I clicked on the green check button… that’s because it didn’t. I brought the website up on my Android device, clicked on the green check button next to one of the fields, and voilla, it turned into a little circle “loading” icon. Afterwards, the “Apply Configuration Changes” popped up, and I was able to click on it, and the changes stuck.

I tried using Mozilla Firefox on the same Windows XP SP3 machine and it DID work. I tried using Internet Explorer 8.0 on a Windows Vista machine just now and it DID NOT work.

I belive the advanced settings page is not compatible with IE8.

Thanks again,

Please file a bug against IE8 providing all the data your provided here.

Include the information about the lack of “Apply Configuration Changes” showing up as well. Thanks.

Ticket 4890