Adjust SMTP Server Address in Old version of FreePBX

Hello, we have a client who is using FreePBX version whose voicemail to email randomly stopped working. In the mail logs, I found that the SMTP host address that they are using somehow got an extra character inputted into it, causing the host name to become invalid.

I cannot for the life of me find where this can be changed though, nothing in the GUI, nothing in the associated .conf files. The system is using Sendmail. It had been working for years just fine. I have read several topics suggesting that Sendmail be uninstalled and install Postfix instead, but I figure there has to be way to adjust this, or else how would it have ever been set up and working in the first place?

Any advice or ideas would be much appreciated, thanks…

If you can’t do it through the GUI then you need to adjust the SMTP settings in the actual config of the service. I think 2.3 still used Postfix. So you need to edit the Postfix config.

But honestly, there’s no support for that box. Both Asterisk and FreePBX versions that are running on it are unsupported and out of date. That box is so old that even the conversion tool they have to update to SN7/FreePBX 14 won’t work on it, they didn’t go that far back for supporting old boxes.

The oldest version of FreePBX that I have personal knowledge of is 2.6 which was over 10 years ago. There was no FreePBX Distro back then, you might be running a scratch install or Asterisk @ Home, not sure if there were any other distros at that time. In any case, every minute you spend propping up an unsupportable system is wasted. It’s time to set up a new system and keep it current this time.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.