Adding userid to outbound IAX trunk dial

I am using Voxee, which requires that the Dial instruction includes my Voxee userid :

exten => _1NXXNXXXXXX,1,Dial,IAX2/[email protected]/${EXTEN}

I have not put anything regarding Voxee into extensions.conf. The default logic seems to execute dialout-trunk which ultimately dials like :

Dial(“SIP/200-e1bc”, “IAX2/voxee/13121234567|120|r”)

How and what do I change to get this to include the userid ? i.e.

Dial(“SIP/200-e1bc”, “IAX2/[color=darkred][email protected][/color]voxee/13121234567|120|r”)

Anthony

You will have to manuall edity your extensions.conf file (or custom one if that’s where the dial line is).
Edit your global section to create a user id field for Voxee

[global]
VEUSERID = myvoxeeID

Then, change the Dial command with IAX2 as its parameter to:

exten => _1NXXNXXXXXX,1,Dial,IAX2/${VEUSERID}@voxee/${EXTEN}

Alternately, you can just hard code your user id into the exten=>_1N Dial line.

I couldn’t find a way in AMP/FreePBX to do this automatically through the browser configuration.