Add new pots lines to freepbx

I had 3 lines installed in the office today and can’t seem to get them to do anything. Telco says they are in the hunt group but I don’t know how to test them. IF I dial the # directly it just rings and never see it in the CLI.

What do I need to configure to see the new lines?

Thanks

I re-punches the lines and all is working. Thanks for the help.

You could physically move the modules to correspond with the ports that are punched down. ie if they are punched on ports 9 through 16 just shuffle the modules down two positions.

Repunch. That will help your sanity 3 years from now!

I think you will be much better off re-punching, lots cheaper (and more understandable) than buying a couple (or three) single port modules. The next quad port module would be on 9,10,11,12. And the quad port module after that one would get the 13,14,15,16. I am unsure how single port modules and/or quad port modules would fit next to each other.

I think (not sure) you can actually rename port 8 to be port 12 (very bad idea imho), but if you don’t physically have the wire connected to the actual port 8 (just renamed port 12) it won’t work. If you do buy a single port module (for port 12) don’t disable port 8. It won’t matter if nothing is connected to it and you may want to use it later too.

Also, I think this is probably more of an asterisk question than a freepbx question. Somebody on Digium’s site should know single vs quad port module compatibility too.

I’m unfamiliar with that hardware, so hope someone else here can jump in and help.

I’m not totally sure what you’re asking, but I believe as long as the analog pair is connected to your card you should see some results in Asterisk when a call comes in. If the pairs are punched down in the wrong place on the block and there’s no physical connection to the TDM card, then no, I don’t think it will work out no matter what settings you try. :slight_smile:

You can see that the scan shows ports 1-8 as FXO. I want to disable port 8 and enable port 12 and so on. I do have all 25 pairs terminated into the both the 66 block and tdm card. So physically they are connected, it is the card that is not looking in the correct place since I only have 2 quad core FXO modules onboard. It is expecting the first 8 ports to have dial tone, when my block has 1,2,3,5,6,12,13,14

port 4 is for fax and not tied into PBX
port 8 is for dedicated alarm and not tied into PBX
other missing # are various other connections on the block

Was hoping I can modifiy channel=12 instead of 8 but not sure if that is how it works or not in dahdi-channels.

[email protected]:/etc/asterisk $ dahdi_scan
[1]
active=yes
alarms=OK
description=Wildcard TDM2400P Board 1
name=WCTDM/0
manufacturer=Digium
devicetype=Wildcard TDM2400P (VPM100M)
location=PCI Bus 08 Slot 06
basechan=1
totchans=24
irq=74
type=analog
port=1,FXO
port=2,FXO
port=3,FXO
port=4,FXO
port=5,FXO
port=6,FXO
port=7,FXO
port=8,FXO
port=9,none
port=10,none
port=11,none
port=12,none
port=13,none
port=14,none
port=15,none
port=16,none
port=17,none
port=18,none
port=19,none
port=20,none
port=21,none
port=22,none
port=23,none
port=24,none

my dahdi-channels.conf

; Autogenerated by /usr/sbin/dahdi_genconf on Wed Nov 17 16:08:36 2010
; If you edit this file and execute /usr/sbin/dahdi_genconf again,
; your manual changes will be LOST.
; Dahdi Channels Configurations (chan_dahdi.conf)
;
; This is not intended to be a complete chan_dahdi.conf. Rather, it is intended
; to be #include-d by /etc/chan_dahdi.conf that will include the global settings
;

; Span 1: WCTDM/0 “Wildcard TDM2400P Board 1” (MASTER)
;;; line="1 WCTDM/0/0 FXSKS (In use)"
signalling=fxs_ks
callerid=asreceived
group=0
;context=from-pstn
context=from-zaptel
channel => 1
callerid=

;;; line="2 WCTDM/0/1 FXSKS (In use)"
signalling=fxs_ks
callerid=asreceived
group=0
;context=from-pstn
context=from-zaptel
channel => 2
callerid=

;;; line="3 WCTDM/0/2 FXSKS (In use)"
signalling=fxs_ks
callerid=asreceived
group=0
;context=from-pstn
context=from-zaptel
channel => 3
callerid=

;;; line="4 WCTDM/0/3 FXSKS (In use)"
signalling=fxs_ks
callerid=asreceived
group=0
;context=from-pstn
context=from-zaptel
channel => 4
callerid=

;;; line="5 WCTDM/0/4 FXSKS (In use)"
signalling=fxs_ks
callerid=asreceived
group=0
;context=from-pstn
context=from-zaptel
channel => 5
callerid=

;;; line="6 WCTDM/0/5 FXSKS"
signalling=fxs_ks
callerid=asreceived
group=0
;context=from-pstn
context=from-zaptel
channel => 6
callerid=

;;; line="7 WCTDM/0/6 FXSKS"
signalling=fxs_ks
callerid=asreceived
group=0
;context=from-pstn
context=from-zaptel
channel => 7
callerid=

;;; line="8 WCTDM/0/7 FXSKS"
signalling=fxs_ks
callerid=asreceived
group=0
;context=from-pstn
context=from-zaptel
channel => 8
callerid=

Connected to a 66 block and then to a Wildcard TDM2400P. the card has 2 - four port cards on it.

I went and checked… I think you are correct. The card is set to accept the first 8 ports the 66 block is using punched down ports over 8 and that is why I don’t see them.

Will have them punched down tomorrow.
awesome job

“awesome job”

Glad a simple question caused a double-check which revealed an answer.

Do I HAVE to repunch the lines on the 66 block or can I configure the TDM card to listen/watch ports I specify?

I see I can buy single port FXO card and made me wonder about that. Seems doable but don’t have a clue.

How are your new lines physically connected to Asterisk?