Activation Error Freepbx

I upgraded from freepbx v15 to V but I am having activation issues.
I get the following error

Error in /var/www/html/admin/modules/sysadmin/Reg.class.php: Exception: Brand file /etc/schmooze/pbx-brand doesn’t exist in /var/www/html/admin/modules/sysadmin/Reg.class.php:156 Stack trace: #0 /var/www/html/admin/modules/sysadmin/Sysadmin.class.php(2226): FreePBX\modules\Sysadmin\Reg->getDeploymentID() #1 /var/www/html/admin/modules/sysadmin/Sysadmin.class.php(528): FreePBX\modules\Sysadmin->doActivateSilent() #2 /var/www/html/admin/libraries/BMO/Ajax.class.php(134): FreePBX\modules\Sysadmin->ajaxHandler() #3 /var/www/html/admin/ajax.php(63): FreePBX\Ajax->doRequest() #4 {main}`

Any ideas on what may be causing this

Can you please ensure that you have all the latest modules?

Sysadmin v16.0.6.2 is the latest one, so please update to this release and give try.


Everything is up to date.
Sysadmin is currently on v16.0.6

V16.0.6.2 is not showing when I check for updates.

16.0.6 also should be fine.
do you have “/etc/schmooze/pbx-brand” or “/etc/sangoma/pbx-brand” file ?
Also is this fresh distro installation ?

I manually upgraded using
fwconsole ma downloadinstall sysadmin --tag
Still no change.

In /etc/schmooze/ there is pbx-brand.rpmsave
In /etc/sangoma/ there is a pbx-brand file

It was a v15 install I was having issues with so I just tried upgrading to v16 using the GUI 15 to 16 Upgrade Tool

Exception says, /etc/schmooze/pbx-brand does not exist , but you are saying this exist. may be try fwconsole chown to confirm this is not a permission issue.

Deleting the .rpmsave extension fixed the error.

Thanks for your help

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.