Activation Error after update to FreePBX 16

Greetings,

I just updated our freePBX-Server to FreePBX 16.0.10.34 using the integrated update tool. Everything worked well and the system is running fine. Just one problem…

System Overview tells me that the server is not registered. So I head to Admin -> System Admin to activate it. When I click on “Activation” I am asked to activate this machine. When I do so, there are different results I get.

The usual message I get is “Activation Error” Unable to display activation page. Error returned was: Operation timed out after 30000 milliseconds with 0 out of -1 bytes received.

Sometimes, usually about every 5th time (approx.) something else happend. The system shows me popups about phones, etc. which I can skip with a button at the bottom. After about 2 to 5 of these popups I get either a window that asks me to enter my portal email-adress (most of the time) and after this, I get a window that tells me that a deployment id exists and asks me if I want to activate the system with this ID or I get the message regarding the deploymend id without the system asking for my portal adress. When I click on “activate” all that happens is, I get the message: “failed to restart apache”.

I checked the web and someone mentioned that it could be a problem with the dns not correctly configured in resolv.conf. I checked the file and added 127.0.0.1 and 8.8.8.8 as nameserver in addition to the ones already there. Did not work…

Someone else mentioned it could be a chown problem, so I ran “fwconsole chown”. Didn’t solve anything.
When I try to restart the apache server manually by entering “/var/html/admin/modules/sysadmin/hooks/restart-apache” I get the following result:

AH00558: httpd: Could not reliably determin the server’s fully qualified domain name, using freepbx.sangoma.local. Set the ‘ServerName’ directive globally to supress this message.

I don’t get a permission denied, but I don’t get a correct “Stopping httpd / Starting httpd” either.

I tried to activate the system via SSH by running fwconsole sysadmin activate XXXXXXXX
and as a result got this:

Attempting to activate against deployment ‘XXXXXXXX’
Running /var/www/html/admin/modules/sysadmin/bin/activate_existing XXXXXXXX
Asking for deployment XXXXXXXX…Success!
Array
(
[Hardware-Locked] => Yes
[Produced-By] => Schmooze Communications
[Product-Name] => PBXact
[Registered-To] => XXXXXXXX
[branding] => FreePBXDistro
[deploy_type] => OSS
[deployment_id] => XXXXXXXX
[deploymentid] => XXXXXXXX
[distributor] => No
[global_lic_exp] => 2045-09-25
[license_version] => 2
[machineid] => 8ecX9c2X955X8a7Xba8X533Xfd3X431Xd5cXe24X6e5XfceXea0X1f9Xb0fXe4eX
[Expires] => 28-Sep-2030
[deployment_name] => XXXXXXXX
)
Setting permissions…
Restarting httpd…
Done

Seems to work, but when open the gui in my browser I get a system not activated message in system overview.

Any idea?

Kind regards,
Chris

Same here.

Please report this issue: issues.freepbx.org

Afterwards, try to activate it from command line: https://wiki.freepbx.org/pages/viewpage.action?pageId=37912685#fwconsolecommands(13+)-SystemAdmin

I reported the issue…

for the activation via command line… doesn’t work here.

Can you elaborate please? What happens when you try to activate?

Hello

I am getting the same problem as the other posters, upgraded to 16 and it wont activate. I have attempted registration from the CLI which seems successful,


But the GUI still reports the installation is un-registered. My previous version (15) was registered fine.
Any further contributions would be welcomed, sorry the uploads are in the wrong order.

Thanks

Try running the following:

fwconsole sa update
service httpd restart

Check if it is now activated. If it does not work, please post the output of both commands

Hi
Thanks for the reply

I ran the commands, see output from console here
SA%20update%20output
The system still does not show as registered in the GUI

Thanks

Nick

At this point, if you are not behind a proxy, then there is nothing the community can do. (System Admin is a commercial module)