Activate FreePBX on raspberry pi

freepbx
Tags: #<Tag:0x00007f7024e022e8>

(Suriname) #41

Here is my link: https://pastebin.freepbx.org/view/14a0199a


#42

It appears that in Settings -> Asterisk SIP Settings, Local Networks is not correctly set. Based on what you’ve posted so far, I assume that it should be
192.168.1.0 / 24
If you had set Local Network on the pjsip tab, it should be the same, or left blank.

You must restart (not just reload) Asterisk after changing any of these settings.

If this is not your issue, please post screenshots of your Asterisk SIP Settings, both General and pjsip tabs.


(Suriname) #43

okay i am going to check


(Suriname) #44

@Stewart1 I have now configured the Local network settings, and I have removed the NAT settings. But now I have only one way audio: https://pastebin.freepbx.org/view/cb59a273


(Suriname) #45

I have removed the Nat settings now, By I still do have audio problems. I sit necessary to have nat settings?


#46

The client devices should not have any NAT options enabled.

pjsip extensions do not have NAT settings per se, but for proper operation whether behind NAT or not, RTP Symmetric, Rewrite Contact and Force rport should all be set to Yes.

In Asterisk SIP settings, External Address and Local Networks should be correctly set. It’s usually not necessary to have any non-default settings for a pjsip transport.

I didn’t see anything wrong with the signaling in your last paste. Possibly, a codec issue; try disabling all but ulaw in Asterisk SIP Settings.

If you still have trouble, please report: On call from 1000 to 1001, which extension can’t hear? On call from 1001 to 1000? On call from 1000 to *43 (echo test), can you hear the announcement? Does the echo test work? On call from 1001 to *43, answer same questions.


(Suriname) #47

I have tested calling 1000 to 1001 again, it seems that the audio drops sometimes. I am going to check that. And thank you for the explanation about NAT.


(system) closed #48

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.