Accessing VM with different context not working

I have a system ready to go live except for 1 small problem. Accessing VM from the users extension using *97 works correctly. Accessing a different mailbox using *98 does not. The problem appears to be that is is sending the context as default to VoiceMailMain instead of the context configured.

For debugging purposes - I tried changing the follow line

exten => _*98.,n,Macro(get-vmcontext,${EXTEN:3})


exten => _*98.,n,Set(VMCONTEXT=teg)

and according to CLI - it was still passing default

Any suggestions?

I believe there is a bug posted against this on the trac system, you may want to check there to make sure the issue is recorded if not.

I have not tried this - but can you pass the VMContext as an argument to VoiceMailMain without an extension? In other words, something like this…

exten => *98.,n,VoiceMailMain(@teg)

Would this set the context correctly? Otherwise, how do I get around this without moving all the users back to the default context?