Access conferences from single inbound number

Hi everybody. I think I really need you help.
Maybe this is an old question, but I can’t find any answer on the forum.
I’trying to let users access conferences dialing an unique company number from outside, then entering into an IVR and choosing the conference by direct dialing the corresponding conference number.

I enabled the IVR option “Enable Direct Dial”, but it works only for real extensions. A “Non valid extension dialed” message occurs if the user directly dials the conference number.

I notice that direct dialing of conference numbers from a telephone inside the company works, and lets the user access the corresponding conference.

There is any trick to reach what I need?
Please, I need your help …
Thanks
g

Is there a chance you can snag the log events from /var/log/asterisk/full that shows the digits being entered into the IVR?

To help with the debugging process, consider adding Misc Application. This will allow you to test the IVR without having to dial through from the outside. Consider something like:

Edit Misc Application:
Description: Testing Conference IVR
Feature Code: 2222 <-- this will be the number you call from inside to test the IVR
Feature Status: Enabled

Destination:
IVR: Conference IVR <-- this will be the name of your IVR

In the end I wonder if the inter-digit time is too fast and the IVR is processing what you’ve entered without getting all the digits for the conference room.

Thanks for your reply, but the problem was elsewhere.
The point is that FreePBX add an “include => from-did-direct-ivr” when you select the “Enable Direct Dial” option in IVR section.
The “from-did-direct-ivr” is a particular context that contains ONLY the real extensions and NOT ringgroups, queues, conferences, etc.
So, from inside the IVR you cannot direct dial something different than a digit (to choose an IVR action) or a real extension number.
This is the architecture of FreePBX.

I succeded in my goal doing this:

  1. Install “Custom Destination module”
  2. Create a new custom destination “conferences,s,1” with whatever description you like (ie “ConferenceIVR”)
  3. Add to /etc/asterisk/extensions_custom.conf the following script

[conferences]
include => ext-meetme; in [ext-meetme] contest are stored all the conferences created in FreePBX
exten => s,1,Answer
exten => s,n,Wait(1)
exten => s,n,Playback(custom/Conferenze-Benvenuto); Insert you welcome message
exten => s,n,Goto(w,1)
exten => w,1,Wait(1)
exten => w,n,Playback(beep)
exten => w,n(begin),Set(TIMEOUT(digit)=3)
exten => w,n,Set(TIMEOUT(response)=10)
exten => w,n,WaitExten(,)
exten => w,n,Playback(invalid)
exten => w,n,Goto(w,1)

This script asks for the conference number to join to and enters the context managing the conferences.
If the conference doesn’t exists, it loops and ask again for a valid conference number.

  1. Create a new Inbound Route and route it to the Custom Destination “ConferencesIVR”
  2. Add your conference room as usual
  3. Enjoy in your new unique conference service number!

Hope it helps
g

Thanks for sharing that code, g_david, it was a big help. I’ve tweaked it slightly as I kept getting booted out since I forgot to wait for the tone. This accepts input at any point:

[conferences]
include => ext-meetme; in [ext-meetme] contest are stored all the conferences created in FreePBX
exten => s,1,Answer
exten => s,n,Wait(1)
exten => s,n,Background(custom/enterConferenceNumber); Insert you welcome message
exten => s,n,Goto(w,1)
exten => w,1,Wait(1)
exten => w,n(begin),Set(TIMEOUT(digit)=3)
exten => w,n,Set(TIMEOUT(response)=10)
exten => w,n,WaitExten(,)
exten => w,n,Playback(invalid)
exten => w,n,Goto(w,1)

below is my /etc/asterisk/extensions_custom.conf but I’m getting the below error and not sure how to fix it. Any help would be greatly appreciated.

Error from log
[Nov 27 19:31:26] WARNING[7156] pbx.c: Invalid extension ‘15’, but no rule ‘i’ or ‘e’ in context ‘conferences’
[Nov 27 19:31:26] VERBOSE[7156] pbx.c: – Executing [[email protected]:1] Hangup(“SIP/172.18.69.17-000009f3”, “”) in new stack

/etc/asterisk/extensions_custom.conf
[conferences]
include => ext-meetme; in [ext-meetme] contest are stored all the conferences created in FreePBX
exten => s,1,Answer
exten => s,n,Wait(1)
exten => s,n,Background(medplus/conf-line); Insert you welcome message
exten => s,n,Goto(w,1)
exten => w,1,Wait(1)
exten => w,n(begin),Set(TIMEOUT(digit)=5)
exten => w,n,Set(TIMEOUT(response)=30)
exten => w,n,WaitExten(,)
exten => w,n,Playback(invalid)
exten => w,n,Goto(w,1)

What have you set up as the destination in you Custom Destination? If you don’t know what I’m asking, look at g_david’s first comment/steps in this thread.

conferences,s,1

Next step then is to define a “Misc Application” with the values:

Description: Conferences
Feature Code: 15
Feature Status: Enabled
Destination:

With that applied you should be able to dial ‘15’ internally and land in your conference room.

Theses are external callers not internal but I did try it but with a 3 and it did not work. So when a user calls in and if they would hit 3 they get disconnected right away. We have no conferences that start with 3 so I would have expected them to get prompted with invalid room and asked for there room again. Thanks for all the suggestions so far

Hi KingPIn did you have any luck with this because I am getting the same issue, sorry I am new to FreePBX

The FreePBX Commercial Module Conference Pro will likely do what you need with a Conference IVR, and is very affordable: http://schmoozecom.com/confpro.php

WIKI LINK: http://wiki.freepbx.org/display/FCM/Conference+Pro