Aastra scripts with 2.10

Has anyone tried Aastra’s XML scripts and FreePBX 2.10? What works, what doesn’t? I’ll probably test myself if no one has crossed this bridge yet…

We have a RPM in the distro. Just yum install aastra-xml-scripts. I did some cleanup to Aastra’s stock scripts to make sure they worked with 1.8 and yes I have them running on 2.10

NO their is no SRPM available for this. Just the RPM’s that you can install and modify.

Nice to hear! Thanks for the work :slight_smile:

Hi Tony, is there a SRPM available for the scripts package? We’ve got a few changes/additions of our own in scripts we run… a lot easier for us to build those changes into an RPM than applying changes manually on every system after installing your RPM.

Cheers,

Mike <<<<<

I’ve completed the “setup-aastra-xml” process as outlined in Aastra Telecom’s document (AastraXMLScripts-PBXFlash-PA-001009-01-03.pdf). However, the mDNS service that is supposedly installed with this process is missing. Of course, the document is dated 2009 and there are a couple of things that are outdated (ie Night/Day Control). But, I’m still digging for info on the “auto-discovery” mechanism. So, have yet to take advantage of the LLDP features.

Will keep posted as progress is made. :slight_smile:

we no longer use mDNS it uses avahi now

Is there any current documentation for this? They always released a document when they released on Trixbox but I haven’t seen anything for what is in the repository.

I am not sure. You would need to look on the Aastra site. Sorry

Few days ago, I tested aastra-xml-scripts-2.3.1-8fpbx.
With aastra-ipphone-3.2.2.1141-2, there is a problem with “Services” menu. Go into “Services” and choose between “Directory”, “Voicemail” or “Application”. Then press “Exit”, and now you can notice that the light of “Services” keeps on. Try to go again in “Services” and it’s impossible. The light goes off after few seconds of inactivity.

I found a second problem, but it could need more test. The visual voicemail doesn’t work when the phone loads lang_fr_ca.txt as module language. For english language, visual voicemail works.

All of this issues, appear only with firmware 3.x
With firmware 2.6 all features work like a charm.

Do the Aastra scripts play nice with the “PBX End Point Manager”? If I’m running strictly Aastra phones is there any point to the “PBX End Point Manager”?

I could install it and play with it but I prefer not to bloat my servers and then have to clean up the mess.

No the scripts do not play nicely with EPM.

Ok, that’s no different than with Trixbox and I’m fine with just the Aastra scripts.

The Aastra firmware package installs to /tftpboot/aastra but the phones try to download from /tftpboot. Does the package install to the wrong location?.. or should the phone be configured differently?.. or is the user expected to move the files after they install?.. or am I the first person this has ever happened to?.. or…

I think the packager decided to separate the firmwares in folder. I got the same problem of firmware location, but you can easily change the path in your aastra.cfg
The only bad thing is the language text file, it seems they need to be in the root of tftpboot and don’t respect the path setting. I will check again to be sure.

something seems to be wrong in the mailboxexists code in aastra-vm.php, when you go to play back a message, I get an error that the mail box doesnt exist:

[Jul 25 12:09:34] VERBOSE[13892] pbx.c:     -- Executing [[email protected]:2] AGI("SIP/256-00000db1", "aastra-vm.php") in new stack
[Jul 25 12:09:34] VERBOSE[13892] res_agi.c:     -- Launched AGI Script /var/lib/asterisk/agi-bin/aastra-vm.php
[Jul 25 12:09:34] VERBOSE[13892] res_agi.c:     -- AGI Script Executing Application: (MailboxExists) Options: (@default)
[Jul 25 12:09:34] VERBOSE[13892] res_agi.c:     -- AGI Script Executing Application: (Playback) Options: (custom/vm-you-no-box)
[Jul 25 12:09:34] VERBOSE[13892] file.c:     -- <SIP/256-00000db1> Playing 'custom/vm-you-no-box.slin' (language 'en')

I’m trying to install the Aastra XML scripts using this command:

rpm -ivh http://yum.freepbxdistro.org/pbx/1.1007.210.62/x86_64/RPMS/aastra-xml/aastra-xml-scripts-2.3.1-90fpbx.noarch.rpm

The install is failing on the dependency avahi. Does anyone know how I might install avahi or is there something else I am missing? I am using the 64 bit version of the Distro.

I want to test to see and see if the XML scripts work correctly with this version of the Distro.

Thanks