Aastra 6739i & XML scripts - voicemail playback not working

Is anyone fighting with this? Aastra 6739i F/W, Aastra XML scripts 2.3.1-0, FreePBX (distro)

Symptom: After completing playback for a voicemail via Aastra XML script the telephone GUI jumps back to the idle screen and does not mark the voicemail as read.

Details: Have tried various firmware versions in the 3.2.1 and 3.2.2 ranges and not much changes…

Yes and the latest beta firmware does not do this for me anymore.

As in

Something like that. Its a non public Beta last time I checked but that seems right.

Hmm, tried that Beta version I mentioned (it’s the newest one I can see) and still no love. These Aastra scripts are gonna be the death of me!

Yes there are lots of problems with them. That is why we wrote out own but I keep trying to help people on the stock scripts but it is getting unmanageable even for us.

What version of the scripts are you using and what version of Asterisk


Aastra XML scripts 2.3.1-0 (I’ve modified demo-user.prf, but mostly as it relates to keys, VLAN, dialplan)

Aastra 6739i Firmware

And this was a clean install with no backup or restore of any old aastra xml configs.

I do see in our yum repo the latest version is aastra-xml-scripts.noarch 2.3.1-1 but that was a minor release.

If that does not solve it not sure what to tell you besides start debugging the XML and the php code.