Aastra 57i CT SIP phone drops call when the "Asterisk" * button is pressed on the phones keypad

I have an issue with an Aastra 57i CT SIP phone running firmware
Whenever I’m on an active call and I press the * button on the phones keypad it drops the connection.

I’ve tried down grading the firmware on the phone to an earlier version etc., Still the same issue.

Not sure if it’s the phone that’s the problem or Asterisk FreePBX?

If anyone else has a Aastra 57i CT SIP phone working with Asterisk FreePBX I’d be interested to know if you to have the same problem.

I’ve worked with Support at Aastra but they don’t seem to have any clue whats causing this…

What do you have the ‘in call Asterisk disconnect code’ set to? This is in Feature codes.

I have tried disabling ‘in call Asterisk disconnect code’ in Feature codes. I have also changed it to something other than the default which is ** but is doesn’t seem to make any difference… As soon as I hit the * it drops the call.

Please post a call trace from the Asterisk CLI try to capture it when no other traffic is on the system.