A200 card - delay the answer signal?

I get robot calls with messages, and when the robot caller detects the A200 card answer, then starts playing its message. By the time the PBX transfer the call, and I answer a good few seconds of the message has already been played,

Anyway to make changes in this behavior?

What would you prefer to do with such a call? And how would the hardware or freepbx know it is a robocall?

I would prefer to answer the call , and be able to hear the beginning.

Then you will have to send all calls direct to an extension , that way the call is only answered when you pick up, alternatively , contact the robocaller and have them not speak until they know you have answered when they call your number. Gotta admit though, you are the first person I have encountered that likes robocalls.

The call is going to a ring group of two extensions. Since the A200 has to complete the circuit to pass the call, that would be an answer.

They are announcements I need to listen to at times, not sales pitches.

In this case, don’t send the call to an extension - send it to voicemail. Write a script that, once a voicemail shows up in the box, create a callfile where your phone is rung and the message is played back.

It has gone to voicemail many times, and it is 5 minutes of music playing, and still the beginning is cut off. Why? because the robocall is detecting the A200 answer, then starts playing the message. I can answer the call on first ring I hear, and a good part of the message has already played.

Do you have


in your dahdi config?

Yes, I have “immediate=no” in chan_dahdi.conf

The whole thing doesn’t compute, I would throw the channel at ‘dhadi_monitor’ as a call comes in and check the recorded file(s)

Let me rephrase, then.

Do not send the call to a phone since that clearly doesn’t work. Send it straight to a “no announcement” voicemail. It will capture everything the channel has to say within 1/10th of a second. Once it’s in voicemail, your BLF will light and you can listen to the message.

If the robocall is coming in that fast, I don’t see how anyone can possibly benefit from it. I mean, it takes me a second or two to get my headset on - are you saying the message is over in that amount of time?

Clearly this is important to you, but it is sounding more and more like this whole scenario was made up. I don’t understand how the announcement can even work if it doesn’t even take the time to see if the message is caught.

The problem with that is there is no caller ID on all the calls.

I’m clearly not understanding what you are driving at now. When did Caller ID enter into the picture? You want a method by which robocalls get answered immediately, but now you want the system to wait until the CID is passed?

With immediate turned off, the DAHDI channel driver will wait until the second ring to get the caller ID information and pass the call to the PBX. The call, at this point, has not been answered yet - it is still ringing.

I’m really not understanding what you are trying to do. Until you can explain it, I’m done looking stupid.

Then do you have callerid enabled on the trunk and appropriately configured with



cidsignalling=(as appropriate)


cidstart=(as appropriate)

in your dahdi config? If you do then dahdi might need to answer the call to get the “spill” If you don’t have that trunk feature, then disable it in dahdi . . .