A200 Analog card start issue

The A200 analog card is installed in a Linux system.
When I ran “wanrouter start” and I got below message:

diag_fld > $wanrouter start

Starting up device: wanpipe1

    wanconfig: WAN device wanpipe1 driver load failed !!
             : ioctl(wanpipe1,ROUTER_SETUP) failed:
             :      22 - Invalid argument


    Wanpipe driver did not load properly
    Please check /var/log/wanrouter and
    /var/log/messages for errors

Configuring interfaces: w1g1 ifconfig: SIOCGIFFLAGS: No such device

done.

diag_fld >

I already ran “wancfg_tdmapi” to create a new wanpipe1.conf as below:

What would be the issue?

Thanks,
Gansheng

diag_fld > $cat /etc/wanpipe/wanpipe1.conf
#================================================

WANPIPE1 Configuration File

#================================================

Date: Mon Jul 31 17:10:23 EDT 2006

Note: This file was generated automatically

by /usr/local/sbin/setup-sangoma program.

If you want to edit this file, it is

recommended that you use wancfg program

to do so.

#================================================

Sangoma Technologies Inc.

#================================================

[devices]
wanpipe1 = WAN_AFT_ANALOG, Comment

[interfaces]
w1g1 = wanpipe1, , TDM_VOICE_API, Comment

[wanpipe1]
CARD_TYPE = AFT
S514CPU = A
CommPort = PRI
AUTO_PCISLOT = NO
PCISLOT = 4
PCIBUS = 2
FE_MEDIA = FXO/FXS
TDMV_LAW = MULAW
TDMV_OPERMODE = FCC
RM_BATTTHRESH = 3
RM_BATTDEBOUNCE = 16
FE_NETWORK_SYNC = NO
MTU = 1500
UDPPORT = 9000
TTL = 255
IGNORE_FRONT_END = NO
TDMV_SPAN = 1
TE_AIS_MAINTENANCE = NO #NO: defualt YES: Start port in AIS Blue Alarm and keep line down
#wanpipemon -i w1g1 -c Ttx_ais_off to disable AIS maintenance mode
#wanpipemon -i w1g1 -c Ttx_ais_on to enable AIS maintenance mode
TDMV_HW_DTMF = YES # YES: receive dtmf events from hardware
TDMV_HW_FAX_DETECT = NO # YES: receive fax 1100hz events from hardware
HWEC_OPERATION_MODE = OCT_NORMAL # OCT_NORMAL: echo cancelation enabled with nlp (default)
# OCT_SPEECH: improves software tone detection by disabling NLP (echo possible)
# OCT_NO_ECHO:disables echo cancelation but allows VQE/tone functions.
HWEC_DTMF_REMOVAL = NO # NO: default YES: remove dtmf out of incoming media (must have hwdtmf enabled)
HWEC_NOISE_REDUCTION = NO # NO: default YES: reduces noise on the line - could break fax
HWEC_ACUSTIC_ECHO = NO # NO: default YES: enables acustic echo cancelation
HWEC_NLP_DISABLE = NO # NO: default YES: guarantees software tone detection (possible echo)
HWEC_TX_AUTO_GAIN = 0 # 0: disable -40-0: default tx audio level to be maintained (-20 default)
HWEC_RX_AUTO_GAIN = 0 # 0: disable -40-0: default tx audio level to be maintained (-20 default)
HWEC_TX_GAIN = 0 # 0: disable -24-24: db values to be applied to tx signal
HWEC_RX_GAIN = 0 # 0: disable -24-24: db values to be applied to tx signal

RM_FAKE_POLARITY = NO
RM_FAKE_POLARITY_THRESHOLD = 16000
RM_FAKE_POLARITY_CIDTIMER = 400
RM_FAKE_POLARITY_CIDTIMEOUT = 4000

RM_RING_DEBOUNCE = 0 #Value in ms: [0,24,32,54] [0 == 54]=Default, Set to lower value if initial ring is very short

[w1g1]
ACTIVE_CH = ALL
MTU = 8
TDMV_HWEC = YES
diag_fld >

Before A200 was installed, A104DE was installed and ran fine.
I also re config and generated new wanpipe1.conf as before mentioned. Thanks,

wanrouter.rc as below:

diag_fld > $cat /etc/wanpipe/wanrouter.rc
#!/bin/bash

router.rc WAN router meta-configuration file.

This file defines variables used by the router shell scripts

and should be located in /etc/wanpipe directory. These are:

ROUTER_BOOT = Boot flag (YES/NO).

WAN_CONF_DIR = Where to put wanpipe config files.

WAN_INTR_DIR = Where to put wanpipe interface files.

WAN_LOG = Where to put start-up log file.

WAN_LOCK = File used as a lock.

WAN_LOCK_DIR =

WAN_IP_FORWARD = Enable IP Forwarding on startup.

WAN_DEVICES = Name of the wanpipe devices to be

loaded on ‘wanrouter start’

(ex: “wanpipe1 wanpipe2 wanpipe3…”)

Note: Name of wanpipe devices correspond

to the configuration files in

WANPIPE_CONF_DIR directory:

(ex. /home/gabblack/cc/gabblack_TRUNK_2/linux/proj/usbc/usbc_gnu_64/os_staging/etc/wanpipe/wanpipe1.conf )

Note: This file is ‘executed’ by the shell script, so

the usual shell syntax must be observed.

ROUTER_BOOT=YES
WAN_CONF_DIR=/etc/wanpipe
WAN_INTR_DIR=/etc/wanpipe/interfaces
WAN_BIN_DIR=/usr/sbin
WAN_LOG=/var/log/wanrouter
WAN_LOCK=/var/lock/subsys/wanrouter
WAN_LOCK_DIR=/var/lock/subsys
WAN_IP_FORWARD=NO
NEW_IF_TYPE=NO
WAN_LIB_DIR=/etc/wanpipe/lib
WAN_ADSL_LIST=/etc/wanpipe/wan_adsl.list
WAN_ANNEXG_LOAD=NO
WAN_SCTP_LOAD=NO
WAN_LIP_LOAD=NO
WAN_DYN_WANCONFIG=NO
WAN_SCRIPTS_DIR=/etc/wanpipe/scripts
WAN_FIRMWARE_DIR=/etc/wanpipe/firmware
WAN_DEVICES_REV_STOP_ORDER=YES
WAN_DEVICES="wanpipe1 "
diag_fld >

A200 is able to see from “wanrouter hwprobe” as below:

diag_fld > $wanrouter hwprobe


Wanpipe Hardware Probe Info
1 . AFT-A200-SH : SLOT=4 : BUS=2 : IRQ=16 : CPU=A : PORT=PRI : HWEC=32 : V=13

Sangoma Card Count: A200=1

diag_fld >

A200 is not able to see from “wanrouter status” as below:

diag_fld > $wanrouter status

Devices currently active:

Wanpipe Config:

Device name | Protocol Map | Adapter | IRQ | Slot/IO | If’s | CLK | Baud rate |

Wanrouter Status:

Device name | Protocol | Station | Status |

diag_fld >