A very very good Caller ID Question!

Hey guys,

 I'll be shocked if anyone knows the answer to this question as I can't seem to find anyone that knows the answer.

I have teliax as a provider. I have follow me setup so that it calls my cell phone. However I can’t get the “caller’s caller id #” passed through to my cell phone. I guess its because I don’t know how, I’ve looked thoroughly but I can’t seem to find the answer.

So my did number lets say is 435-555-1234 which is registered with teliax.  Which I have setup in FreePBX anyways when people call that number I can see their orginal number in my reports. But is it possible when lets say they dial 1 to reach me at my cell phone, is it possible to have their number routed through "follow me" well basically have it routed so that when it rings to my cell phone it shows their orginall caller id number?  But as of now it just shows my DID number on my cell phone.  


Any thoughts or ideas/ help on this would be great!!  

what you want is the default behavior of FreePBX. However, it is very likely that teliax is not passing the CID. You can test this by setting the outbound cid of your extension to something else, then call an external number (like your cell phone) and see if that new CID is being sent. If not - it is teliax not accepting the number. If yes, then there may be an issue with how you have your trunk setup. If teliax is blocking it - go to your teliax account page. They have a setting but I don’t recall exactly where, that you can control whether you are allowed to set cid or not. So that may be the issue right there. (You may want to check that first before running through all the tests above).

  I'm assuming Teliax is allowing the CID to pass, because in the freepbx history reports I can see all the oringal callers caller id's.  So if I can see all that, is it possible Teliax would still be blocking the CID in the sense of not letting them pass?  I have tried setting an outbound caller id number but that doesn't seem to change it, I have even tried the Emergency CID which is supposed to override all the settings from what I understand. I've kept everything really simple and everything is as close to default that I know of except for just changing the settings to set things up to route to my cell phone.  

         Anymore ideas? or thoughts or suggestions?

           I'm very grateful for any help. Thanks soo much!!

                        - Nick

If you put an outboundcid in the extension, and then call out that trunk to your cell phone, and you don’t see that outboundcid, then it is not passing it. (Make sure to put another number other than the teliax number for your outboundcid).If this is the case, go to your teliax portal and enable the feature, and make sure your teliax trunk is setup right (no fromuser iirc).

Does this look right?
this is what I have setup for my trunk

this is my peer details

allow=ulaw
auth=md5
context=default
disallow=all
host=voip-co3.teliax.com
nat=yes
secret=******
type=friend
username=********

and this is my user details

allow=ulaw
auth=md5
context=from-pstn
disallow=all
type=user

I too was perplexed by this. CallerID not showing up as I wanted it.

I’m using les.net and followed their instructions for setting up a trunk by copy/paste.

There’s one line that you SHOULDN’T copy to make CallerID from your asterisk pass as wanted.

fromuser=xxxxxxxxx

What ever you put in there, will be your caller ID passed.

So here’s my trunk settings that worked for me:
OUTGOING
canreinvite=no
context=from-trunk
host=did.voip.les.net
insecure=very
nat=yes
secret=***********
type=peer
username=*********

INCOMING
canreinvite=no
context=from-trunk
insecure=very
nat=yes
type=user

BTW: I’ve only been playing with this freepdx for about 8 hrs total, so I am able to see the solution as the simple one. All the help I’ve tried to see on this focuses on the “complex” problems that must be there. Kinda like checking to make sure the power light is on first.