A Remote Extension Issue

Need a bit of help here as have been trying to sort this for a number of days.

Have read as many posts as I can, but cannot seem to find a resolution specific to my issue.

The issue is as follows.

Running Freepbx on a dedicated box on a local LAN behind a router/firewall (D-Link D-615 C2)

All internal calling between extensions works fine (using PC based softphones internally) and calling out through external VoIP provider works fine (pennytel)

The issue comes with my remote softphones (running on iphones) when outside the office environment

I can make calls from the remote softphone back into the office extensions no problem

I can make calls from the remote softphone, back through the office system and out on the external VoIP provider no problem

I cannot make calls from within the office out to the iphone softphones (running on Telstra 3G when out of office).

When I am on external 3G network and force the softphones to re-register, my softphone clients running locally on the PC will show the remote phones momentarily connect, then says they go off-line within a few seconds. If I am quick and make the call when the local PC softphones pick-up the remote registration, I can make the call, but as soon as I hang-up I cannot make any further calls out.

The Freepbx System Status shows the remote softphones as on-line all the time when they are there and off-line when they are off.

Funny thing is, if I bring the iphone softphones into the office environment and hook to the local wireless LAN, the system will fully function, even with the external IP address and everything still set on the iphones, so could it be the way the iphone/3G combination works and staying alive?

My extensions are enabled for NAT and the system knows what are internal/external addresses.

Have tried multiple softphone clients on both the PC and Phone

Have tried with and without STUN, but not sure if I know what I am doing with that. On the Bria softphone client, they say not to rely on their STUN server, so not sure if I have actually used stun.

Any help much appreciated as I am pulling my hair out.

PS Just been looking at the SIP peer information under the Astericks info in reports. The host IP that is showing for the phone when it is in the field and registered, looks totally different ( to what my phone tells me when I run a check on “whatismyip” from a browser on the phone ( It also says “possible proxy detected” so that maybe where my issues are coming from, though no idea what to do about it.



Using remote extensions creates a huge security hole and causes all manner of trouble. Here are some suggestions:

  1. Sign up for a separate VOIP provider for your Remote phones, and use their internal routing to connect your remote phones and your PBX. Both Callcentric and VOIP.ms allow routing of calls between sub-accounts.

  2. Have you tried using your iPhone on Wifi? Does it work or not?

  3. Have you tried using a different SIP Signalling Port?

  4. Have you read the Asterisk Log?

cd /var/log/asterisk
nano full

CTRL-X to exit.

What does it say?

And if I had to guess, I’d guess that you are having a NAT issue. Have you enabled NAT both in the extension settings and in the Asterisk SIP Settings?

Regarding #2: I mean, Wifi outside of your office, i.e. at Starbucks or somewhere other than the location where the PBX is.

i have the same issue, when using a 3G Line, the extension able to register but it hangup after 2 rings. when i am in my local network this does not happen. only in 3g line. When i am using a hotspot connections like in coffee shop, the issue never occur.