*97 working like *98

Sep 10, 2009

FreePBX 2.5

Hi

I added 4 new extensions today (7521,7522,7523,7524),
and when I check for voice mail messages using *97,

The system responds with “COMEDIAN MAIL, Please enter your box number and password”.

So I enter in the current box number and passwords,
and the system NEVER allows you access,
claiming the password is not correct.

On other extension that I have previously created, the system responds NORMALLY with the question “Please enter your password”, NOTHING said about “COMEDIAN MAIL” or enter your BOX NUMBER, the system detects this automatically and when you provide the proper password, the system allows you access.

Why is *97 not working appropriately for these new box number,
This is strange behavior, What could be the problem ?

Thank you
Walt

Have you looked at “Misc Destinations” in the menu?
*98 is voice mail by default.

Hi

Thank you for your response
But I am not understanding what you mean.

when I Press *97 it acts like *98 (requiring a user name and password)
and login is never allowed

Normally - when I pres *97 - it automatically logins using your extension
and all you need to provide is the passcode

It is not working like this on the new extension I setup the other day

Do you have a solution ?

Thank you
Walt

You still never answered my question “Have you looked at “Misc Destinations” in the menu?”

Take a look there first

How can it not mean a lot to you? That is where you define to dial destinations such as voice mail.

Look at see what you have setup there. Take the time to read it.

Yes - I looked at Misc Destination
It doesnt mean much to me

Like I said - I have alot of extensions

When I dial *97 on all but most recent extensions added,
they work just fine.(People login to their voicemail without any problems)

However…
The new extensions I created recently,
do not work like the previous extensions.

When I dial *97 on these new extensions,
the system responds "COMEDIAN MAIL, ENTER YOUR MAIL BOX & PASSWORD"
and when I input the proper credentials,
the system tells me they are not correct,
and does not allow me to login

How does “Misc Destinations” resolve this behavior

Thank you
Walt

The solution GeekBoy is providing is not correct.
Open up a command line to asterisk asterisk -r then turn on some debugging with set verbose 5. Dial *97, enter extension number and password.
Post the debug file here with just that part so that I can see what is going on.
Please post the output inside code tags with [ ] surrounding the word code.

How is it not correct? That is the first place he should look to make sure the “Misc Destinations” code is set correctly.

He tries to use *97 which is a feature code in FreePBX that takes the extension from the phone and asks for a password. Look in Feature Codes in section Voicemail there it is, My Voicemail Feature Code *97.

His problem is that it does not work. That is why I ask for a call trace to be able to see where in the dial plan it goes wrong.

Well my voice mail by default is *98 when I installed it. I have nothing assigned to *97
That is why he needs to look at it to make sure the correct code is still in there. Only takes 2 seconds.

Hi
Thank you for your response

I tried this in FreePBX InterFace - sys says no such command
So I openEd putty and logged in: and tried it again, I hope this is what you need.

I created a new box 219 - yesterday, --> this mail box does not work
Sys will not allow me to access voice mailbox 219 USING *97 NOR *98

old mail box 201 - this works fine - when I dial *97 no problems

I see that the system has used up 85% of hard drive space,
I don’t know if this has anything to do with this behavior

Thank you
Walt

EXT 219 - DOES NOT WORK - SETUP 1 DAY AGO

Connected to Asterisk 1.4.15 currently running on pbx (pid = 2947)
Verbosity is at least 3
pbxCLI> asterisk -r
No such command ‘asterisk -r’ (type ‘help’ for help)
pbx
CLI> aserisk -r
No such command ‘aserisk -r’ (type ‘help’ for help)
pbx*CLI> verbose 5
No such command ‘verbose 5’ (type ‘help’ for help)
– Registered SIP ‘2126’ at 192.168.0.235 port 5060 expires 120
– Registered SIP ‘2126’ at 192.168.0.222 port 5060 expires 120
– Registered SIP ‘219’ at 71.57.163.144 port 2530 expires 3600
– Unregistered SIP ‘219’
– Registered SIP ‘219’ at 71.57.163.144 port 2530 expires 3600
– Executing [*[email protected]:1] Answer(“SIP/219-098a7138”, “”) in new sta ck
– Executing [*[email protected]:2] Wait(“SIP/219-098a7138”, “1”) in new stac k
– Executing [*[email protected]:3] Macro(“SIP/219-098a7138”, "user-callerid| ") in new stack
– Executing [[email protected]:1] Set(“SIP/219-098a7138”, “AMPUSER=219” ) in new stack
– Executing [[email protected]:2] GotoIf(“SIP/219-098a7138”, “0?report” ) in new stack
– Executing [[email protected]:3] ExecIf(“SIP/219-098a7138”, “1|Set|REA LCALLERIDNUM=219”) in new stack
– Executing [[email protected]:4] Set(“SIP/219-098a7138”, “AMPUSER=219” ) in new stack
– Executing [[email protected]:5] Set(“SIP/219-098a7138”, “AMPUSERCIDNA ME=219”) in new stack
– Executing [[email protected]:6] GotoIf(“SIP/219-098a7138”, “0?report” ) in new stack
– Executing [[email protected]:7] Set(“SIP/219-098a7138”, “AMPUSERCID=2 19”) in new stack
– Executing [[email protected]:8] Set(“SIP/219-098a7138”, “CALLERID(all )=“219” <219>”) in new stack
– Executing [[email protected]:9] ExecIf(“SIP/219-098a7138”, “0|Set|CHA NNEL(language)=”) in new stack
– Executing [[email protected]:10] GotoIf(“SIP/219-098a7138”, “0?contin ue”) in new stack
– Executing [[email protected]:11] Set(“SIP/219-098a7138”, “__TTL=64”) in new stack
– Executing [[email protected]:12] GotoIf(“SIP/219-098a7138”, “1?contin ue”) in new stack
– Goto (macro-user-callerid,s,19)
– Executing [[email protected]:19] NoOp(“SIP/219-098a7138”, “Using Call erID “219” <219>”) in new stack
– Executing [*[email protected]:4] Macro(“SIP/219-098a7138”, “get-vmcontext| 219”) in new stack
– Executing [[email protected]:1] Set(“SIP/219-098a7138”, “VMCONTEXT=de fault”) in new stack
– Executing [[email protected]:2] GotoIf(“SIP/219-098a7138”, "0?200:300 ") in new stack
– Goto (macro-get-vmcontext,s,300)
– Executing [[email protected]:300] NoOp(“SIP/219-098a7138”, “”) in new stack
– Executing [*[email protected]:5] MailboxExists(“SIP/219-098a7138”, “[email protected] fault”) in new stack
– Executing [*[email protected]:6] GotoIf(“SIP/219-098a7138”, “0?mbexist”) i n new stack
– Executing [*[email protected]:7] VoiceMailMain(“SIP/219-098a7138”, “”) in new stack
– <SIP/219-098a7138> Playing ‘vm-login’ (language ‘en’)
– <SIP/219-098a7138> Playing ‘vm-password’ (language ‘en’)
– Incorrect password ‘’ for user ‘219’ (context = default)
– <SIP/219-098a7138> Playing ‘vm-incorrect-mailbox’ (language ‘en’)
– Registered SIP ‘2126’ at 192.168.0.235 port 5060 expires 120
– Registered SIP ‘2126’ at 192.168.0.222 port 5060 expires 120
– <SIP/219-098a7138> Playing ‘vm-password’ (language ‘en’)
– Incorrect password ‘219’ for user ‘219’ (context = default)
– <SIP/219-098a7138> Playing ‘vm-incorrect-mailbox’ (language ‘en’)
– Executing [[email protected]:1] Macro(“SIP/219-098a7138”, “hangupcall”) in new stack
– Executing [[email protected]:1] GotoIf(“SIP/219-098a7138”, “1?skiprg”) in new stack
– Goto (macro-hangupcall,s,4)
– Executing [[email protected]:4] GotoIf(“SIP/219-098a7138”, “1?skipblkvm”) in new stack
– Goto (macro-hangupcall,s,7)
– Executing [[email protected]:7] GotoIf(“SIP/219-098a7138”, “1?theend”) in new stack
– Goto (macro-hangupcall,s,9)
– Executing [[email protected]:9] Hangup(“SIP/219-098a7138”, “”) in new stack
== Spawn extension (macro-hangupcall, s, 9) exited non-zero on ‘SIP/219-098a7138’ in macro ‘hangupcall’
== Spawn extension (macro-hangupcall, s, 9) ex

EXT201 - WORKS FINE - SETUP A LONG TIME AGO
Connected to Asterisk 1.4.15 currently running on pbx (pid = 2947)
Verbosity is at least 3
– Executing [*[email protected]:1] Answer(“SIP/201-09928388”, “”) in new stack
– Executing [*[email protected]:2] Wait(“SIP/201-09928388”, “1”) in new stack
– Executing [*[email protected]:3] Macro(“SIP/201-09928388”, “user-callerid|”) in new stack
– Executing [[email protected]:1] Set(“SIP/201-09928388”, “AMPUSER=201”) in new stack
– Executing [[email protected]:2] GotoIf(“SIP/201-09928388”, “0?report”) in new stack
– Executing [[email protected]:3] ExecIf(“SIP/201-09928388”, “1|Set|REALCALLERIDNUM=201”) in new stack
– Executing [[email protected]:4] Set(“SIP/201-09928388”, “AMPUSER=201”) in new stack
– Executing [[email protected]:5] Set(“SIP/201-09928388”, “AMPUSERCIDNAME=Walt-BV”) in new stack
– Executing [[email protected]:6] GotoIf(“SIP/201-09928388”, “0?report”) in new stack
– Executing [[email protected]:7] Set(“SIP/201-09928388”, “AMPUSERCID=201”) in new stack
– Executing [[email protected]:8] Set(“SIP/201-09928388”, “CALLERID(all)=“Walt-BV” <201>”) in new stack
– Executing [[email protected]:9] ExecIf(“SIP/201-09928388”, “0|Set|CHANNEL(language)=”) in new stack
– Executing [[email protected]:10] GotoIf(“SIP/201-09928388”, “0?continue”) in new stack
– Executing [[email protected]:11] Set(“SIP/201-09928388”, “__TTL=64”) in new stack
– Executing [[email protected]:12] GotoIf(“SIP/201-09928388”, “1?continue”) in new stack
– Goto (macro-user-callerid,s,19)
– Executing [[email protected]:19] NoOp(“SIP/201-09928388”, “Using CallerID “Walt-BV” <201>”) in new stack
– Executing [*[email protected]:4] Macro(“SIP/201-09928388”, “get-vmcontext|201”) in new stack
– Executing [[email protected]:1] Set(“SIP/201-09928388”, “VMCONTEXT=default”) in new stack
– Executing [[email protected]:2] GotoIf(“SIP/201-09928388”, “0?200:300”) in new stack
– Goto (macro-get-vmcontext,s,300)
– Executing [[email protected]:300] NoOp(“SIP/201-09928388”, “”) in new stack
– Executing [*[email protected]:5] MailboxExists(“SIP/201-09928388”, “[email protected]”) in new stack
– Executing [*[email protected]:6] GotoIf(“SIP/201-09928388”, “1?mbexist”) in new stack
– Goto (from-internal,*97,106)
– Executing [*[email protected]:106] VoiceMailMain(“SIP/201-09928388”, “[email protected]”) in new stack
– <SIP/201-09928388> Playing ‘vm-password’ (language ‘en’)
– <SIP/201-09928388> Playing ‘vm-youhave’ (language ‘en’)
– <SIP/201-09928388> Playing ‘vm-no’ (language ‘en’)
– <SIP/201-09928388> Playing ‘vm-messages’ (language ‘en’)
– <SIP/201-09928388> Playing ‘vm-opts’ (language ‘en’)
== Spawn extension (from-internal, *97, 106) exited non-zero on ‘SIP/201-09928388’
– Executing [[email protected]:1] Macro(“SIP/201-09928388”, “hangupcall”) in new stack
– Executing [[email protected]:1] GotoIf(“SIP/201-09928388”, “1?skiprg”) in new stack
– Goto (macro-hangupcall,s,4)
– Executing [[email protected]:4] GotoIf(“SIP/201-09928388”, “1?skipblkvm”) in new stack
– Goto (macro-hangupcall,s,7)
– Executing [[email protected]:7] GotoIf(“SIP/201-09928388”, “1?theend”) in new stack
– Goto (macro-hangupcall,s,9)
– Executing [[email protected]:9] Hangup(“SIP/201-09928388”, “”) in new stack
== Spawn extension (macro-hangupcall, s, 9) exited non-zero on ‘SIP/201-09928388’ in macro ‘hangupcall’
== Spawn extension (macro-hangupcall, s, 9) exited non-zero on ‘SIP/201-09928388’

Hmmm,

Note the part

-- Playing 'vm-password' (language 'en')
-- Incorrect password '' for user '219' (context = default)
-- Playing 'vm-incorrect-mailbox' (language 'en')

Compare your output against mine:

-- <SIP/777777-085c4c68> Playing 'vm-password' (language 'en')
-- Incorrect password '8888' for user '777777' (context = default)
-- <SIP/777777-085c4c68> Playing 'vm-incorrect' (language 'en')

It seems that it wont detect the DTMF you send from the phone. What phone are you using for that extension?

Hi

We have Polycom Phones at the office. I am using X-Lite.
Same issues with both phones

All my OLD extensions - work fine
All NEW extensions - Do not access Voice Mail

I gave you a test for ext201 and ext219

ext201 - I have had since the system was built
ext219 - I registered just yesterday

from the polycom phones
ext201 - works fine
ext219 - does not

from x-lite
ext201 - works fine
ext219 - does not

It is strange behavior

I added a new extension about 2 weeks ago - and that ext works fine
since then all new extension - are not working properly
we are able to dial out - no problem
receive incoming calls - no problem
but - access voice mail - is a problem
we dial *97, and it behaves as if you dialed *98
and the sys will never accept a valid password

Any solutions ?

Thank you
Walt

Ok, two things.

First, check your voicemail.conf file so that the extension 219 exist in that file and that the password is correct.

Second, there is no mailbox created until someone leaves a voicemail to the new extension, in this case 219.

If you dial *98 and enter extension (219) and password it should create the necessary directory structure.

After that you should be able to use *97 to check your voicemail.

I should have noted that when I looked at the log file.

Her it is with a valid mailbox, note the second line, it checks if a mailbox exists then go down in the dialplan to VoiceMailMain.

-- Executing [*[email protected]:5] MailboxExists("SIP/201-09928388", "[email protected]") in new stack
-- Executing [*[email protected]:6] GotoIf("SIP/201-09928388", "1?mbexist") in new stack
-- Goto (from-internal,*97,106)
-- Executing [*[email protected]:106] VoiceMailMain("SIP/201-09928388", "[email protected]") in new stack

Here is the new extension, note that it does not jump down in the dialplan, it just goes to the next line calling VoiceMailMain without extension or context:

-- Executing [*[email protected]:5] MailboxExists("SIP/219-098a7138", "[email protected]") in new stack
-- Executing [*[email protected]:6] GotoIf("SIP/219-098a7138", "0?mbexist") in new stack
-- Executing [*[email protected]:7] VoiceMailMain("SIP/219-098a7138", "") in new stack

Check your directory structure in /var/spool/asterisk/voicemail/default (If I am correct, this is from memory, I don’t have any system in front of me right now) if there is a directory called 219

Hi

And thank you for your help

I have found the problem !!

And this is not the first time something like this has happened.

The “voicemail.conf” file is sometimes corrupted for some unknown reason

I found
[]
[]
[]
between old extension boxes and the new extension boxes I created
and therefore all the new boxes after these brackets, I had problems with the voicemail. All extension boxes before the brackets work as normal

I am not sure why this occurs, but I remember fixing a similar problem,
where I had to remove these unknown brackets []

Also - Even when you re-create the boxes, and re-submit in hopes of resolving any potential issues, does not help much.

Thank you
Walt

I can confirm the exact same issue and solution found by Walt.

BACKGROUND
Fresh install of FreePBX 2.5.2.2 from AsteriskNOW. Set up extensions, etc etc. Weird thing noticed when setting up extensions is that selecting the “enabled” for voicemail did not let me set up the voicemail details. For each extension, it wasn’t until I Applied Configuration Changes that it then allowed me to setup the voicemail password and such. Weird.

THE PROBLEM
Anyway, dialing either *97 or *97 resulted in the COMEDIAN MAIL… prompt and never ever was I able to get it to accept the password. I got the same “incorrect password” responses and the logfiles always said something like:

– Executing [*[email protected]:18] NoOp(“SIP/302-0000000e”, “app-dialvm: Asking for mailbox again”) in new stack
– Executing [*[email protected]:19] Read(“SIP/302-0000000e”, “MAILBOX|vm-incorrect-mailbox|||3|2”) in new stack
– <SIP/302-0000000e> Playing ‘vm-incorrect-mailbox’ (language ‘en’)

When I tried to leave a message at extension 302, I got the following:

app_macro.c: Executed application: VoiceMail
logger.c: – Executing [[email protected]:4] Goto(“SIP/302-0000000f”, “exit-FAILED|1”) in new stack
logger.c: – Goto (macro-vm,exit-FAILED,1)
app_macro.c: Executed application: Goto
logger.c: – Executing [[email protected]:1] Playback(“SIP/302-0000000f”, “im-sorry&an-error-has-occured”) in new stack
logger.c: – <SIP/302-0000000f> Playing ‘im-sorry’ (language ‘en’)
logger.c: – <SIP/302-0000000f> Playing ‘an-error-has-occured’ (language ‘en’)

SIDE NOTE #1
Interesting enough, I decided to look at /var/spool/asterisk/voicemail and THERE WAS NO “default” directory… There was a “device” directory and below /device eac extension was linked to the nonexistent /var/spool/asterisisk/voicemail/default/xxx path. Weird.

CONFIRMED ISSUE
Similar to what Walt found, there were extra blank bracket lines that FreePBX had somehow managed to create in /etc/asterisk/voicemail.conf For example, mine looked like this:

[[email protected] asterisk]# more voicemail.conf
[general]
#include vm_general.inc
#include vm_email.inc
[default]

[]
[]
[]
100 => 100,myname,[email protected],=
[]
304 => 304,name,[email protected],attach=yes|saycid=yes|envelope=yes|=

THE CONFIRMED FIX:
A simple > sudo nano /etc/asterisk/voicemal.conf and removed the lines with blank brackets.

And now everything (*97 and *98) appear to work fine. SIDE NOTE #2: There is now a /var/spool/asterisk/voicemail/default directory.

Perhaps FreePBX has some setup issues or inability to clean out junk “[]” in .conf files. Either way, a manual editing was definitely required at this point (I tried re-creating boxes, upgrading voicemail, etc, and nothing worked).

_Red

“it wasn’t until I Applied Configuration Changes that it then allowed me to setup the voicemail password and such. Weird”

In order for any changes to be instigated by Asterisk, you must “Apply Configuration Changes”. I would say that it’s normal behaviour. The changes do not exist in Asterisk until applied. So you can’t setup a voicemail password until the extensions exist. Maybe I’m not reading your response properly?

Check this:

http://www.freepbx.org/forum/freepbx/installation/im-sorry-an-error-has-occurred-voice-mail-new-install

This threads are related to the same issue.

Hi everyone - Happy Holidays and Happy New Year

I believe there is a problem with the Extensions Module

On occasion, the Extensions module may (for some unknown reason) generate these brackets [].

This has happened twice for me where these brackets mysteriously appeared when createing new extensions.

If you see these brackets [] in your voicemail.conf file, simply edit it and remove them. This should resolve any problems.

Hopefully, Tech Support would read these issues, and attempt to correct it.

Thank you
Walt