7777 - simulate internal call not working


I’m trying to work out why feature code 7777 is not working. I can’t test my IVR otherwise as I don’t have outbound/inbound external lines (DDI/ITSP).

This is the log that i’m getting from the Asterisk command line -


Any help would be gratefully received, I have scouted around the forums and looked on Google.

I have however updated asterisk using YUM updates but I failed to realise that you apparently need to delete the previous modules before you update.

Please guide me…

Kind Regards,


I have set up an inbound route that is blank other than that it redirects to ivr as I was advised. This hasn’t changed things. Still not working.

Also it is saying the number is not in service as opposed to cannot be completed as dialed (the latter would be the case if the number was not recognised)

To test your IVR set up a MISC APPLICATION that points to that IVR, you can view the user guide here: http://wiki.freepbx.org/display/F2/Misc+Applications

Hello, Thanks for your message, there is no misc in the applications menu. I’m running Free PBX I have set up an inbound route as advised with everything blank except for the IVR choice at the bottom, that’s at least what I was previously advised :slight_smile:

Thanks and Kind Regards,


This issue related to NAT problems, I changed some of these settings within FreePBX and this appeared to resolve the issue. I learnt that NAT settings within Asterisk SIP Settings are totally independent of those for individual extensions.

Further - anybody else reading this article, please note, an inbound route that is totally blank (you can give the route a name if you wish) is necessary with totally otherwise blank settings - (use defaults etc) and forwarding to IVR - name of top level IVR (whatever this is) is necessary in order for 7777 to work.

—Issue resolved.