*77 Feature not working (System Record)

I’m using the latest Asterisk 1.4.13 and FreePBX 2.3.1.0 and I cannot use the *77 feature to record system messages.
If I go to the “System Recordings” tab in the web UI, the page displays the following error after I enter my extension number:

“Using your phone,dial ** MISSING FEATURE CODE ** Start speaking at the tone. Hangup when finished.and speak the message you wish to record.”

I try dialing *77 anyway, and I get the message “That feature is unavailable”.
The debug output is:

    -- Executing [*[email protected]:1] ResetCDR("SIP/100-b4006130", "") in new stack
    -- Executing [*[email protected]:2] NoCDR("SIP/100-b4006130", "") in new stack
    -- Executing [*[email protected]:3] Wait("SIP/100-b4006130", "1") in new stack
    -- Executing [*[email protected]:4] Playback("SIP/100-b4006130", "silence/1&feature-not-avail-line&silence/1&cannot-complete-as-dialed&check-number-dial-again|noanswer") in new stack
    -- <SIP/100-b4006130> Playing 'silence/1' (language 'en')
    -- <SIP/100-b4006130> Playing 'feature-not-avail-line' (language 'en')

Can anyone please help? I really need to use this feature.

check featurecode admin to make sure it is enabled.

Philippe Lindheimer - FreePBX Project Lead
http//freepbx.org - IRC #freepbx

Yes, I have “Feature Code Admin” enabled:

In the “Module Admin” tab I get:
Feature Code Admin setup 1.0.5.3 Enabled

Any other suggestions?

In my Feature Codes Admin, I only have the following feature codes available to me:

Call Forward
Call Forward All Activate 			
Call Forward All Deactivate 			
Call Forward All Prompting Deactivate 			
Call Forward Busy Activate 			
Call Forward Busy Deactivate 			
Call Forward Busy Prompting Deactivate 			
Call Forward No Answer/Unavailable Activate 			
Call Forward No Answer/Unavailable Deactivate 			
Core
Call Pickup (Can be used with GXP-2000) 			
ChanSpy 			
Simulate Incoming Call 			
Simulate Incoming FAX Call 			
User Logoff 			
User Logon 			
ZapBarge 			
Do-Not-Disturb (DND)
DND Activate 			
DND Deactivate

Thanks for the help! I appreciate it! I really hope you guys can help me get this fixed…

Ok, I solved this problem by deleting Feature Code Admin module and then re-installing it.

*77 seems to conflict with *7777.

Change the system record to something other than *77. I use *44 and it works fine.

Go to feature codes and change to *44 there.

There is a feature code for 7777 (note the lack of *) which simulates you calling into the system form the extension you are dialing it on.

I’d talk to the person who setup your system about why they picked a overlapping dial pattern and get that addressed properly.

I’m a DIY’er that has my system running nicely. I have setup 3 servers in total and the *77 never worked. I just change it to something else and it works like a charm. I was just trying to give something back to this community which always seems to have the answers to my ?'s here somewhere. I spent 3 hours figuring this out the first time. Not sure why *77 does not work…it just doesn’t. Thanks, Max

Max, what I was trying to point out that It would not work if you have two codes defined with overlapping patterns, it would take one before the other. Also that the system defaults don’t have a code for *7777 for that reason.

Info to try and help you and others out:

The most common reason that *77 ( *1 for on demand recording or any other code starting with * for that matter not working) is that the phone you are using has a built in dialplan that say’s what is a valid dialing string and what is not. If it does not have the *xx or *xx+, etc in the plan on the phone it would consider it a invalid dialed code and not pass it out of the phone to the system.

We had the same issue with the stock patterns provided on a few different manufactures phones we tested. This is also very important if you are using a ATA as they all have a dialplan in them. About the only time it’s not important is if you use analog phones with a direct connection via analog card installed into the server. Then it goes directly into the asterisk dialplan without any pre-processing or filtering.

good info. Is that possible why paging codes would not work. I think you answered another question I had. Thanks, Max

yep as they also use the *x format.