FreePBX | Register | Issues | Wiki | Portal | Support

5.211.65-X to 6.12.65 upgrade script


(Andrew Nagy) #22

command is asterisk-version-switch


#23

Thanks, it works.

After reboot I don’t see errors. It seems to be ok, but the web interface isn’t changed at all, and I can’t find the new user control panel…

I’m a newb… I try to find the new interface :smile:


(Andrew Nagy) #24

I don’t know what you expect to be different. Most of it is the same. Can you provide screenshots.


#25

I expect freepbx 12.0.1beta16 like in the screenshot posted by parnassus, but I’m on freepbx 2.11.


#26

You are only switching Asterisk, not FreePBX


#27

Actually I run your script to upgrade from 5.211.65-14 to 6.12.65-13. Only after the upgrade I run the asterisk-version-switch to switch to asterisk 12.

By the way, upgrading to 6.12.65-12 I expect freepbx12
I apologize if I’m wrong


(Andrew Nagy) #28

I don’t understand how you are on 2.11 still. It’s nearly impossible for that to happen unless it couldn’t connect to the database as root because you changed the root password. If you did that then you are SOL


#29

I revert to 5.211.65.9. I don’t remember if I changed the root password.
Some days ago I upgraded ghostscript to 9.14. Do you think this can be related to this issue?


(Andrew Nagy) #30

Doubtful, without seeing the install log I have nothing to go on. Just type “mysql” and see if you can connect manually


#31

I look in amportal.conf the ampdbuser and ampdbpassword.
using the password I found, ‘mysql -u freepbxuser -p’ give me the access to DB.

I also can use root with blank password, so I think that I’m on a standard configuration.

I’d like to retry the upgrade of my freepbx VM, but where is the upgrade log files?


#32

Well,
I don’t find the log, but during the upgrade I see:
FreePBX has not been upgraded. Please upgrade FreePBX through Module Admin.

and

PHP Fatal error: Class ‘FreePBX’ not found in /var/www/html/admin/modules/userman/functions.inc.php on line 14

so I deleted the userman directory, but after a amportal a r I see:

PHP Fatal error: Call to a member function registerHook() on a non-object in /var/www/html/admin/modules/xmpp/functions.inc/userman_hook.php on line 24
[root@pbx upgrade]# amportal a r

so I deleleted the xmpp folder and freepbx start to works.

Now in the module admin I can Upgrade the framework 12.0.1beta19

I know that this is not the correct way to upgrade, but I’d like to try the new interface.


#33

Ok,
I reverted to 6.11.65-14
I uninstalled the userman & xmpp
I ran the upgrade script to upgrade to 6.12.65, and now the Whole system il upgraded even the web interface.
Very very nice!
The only issue I found is that I’m not able to login into the UCP with extension/voicemail password.


(TheJames) #34

Did you enable the user in userman


(Andrew Nagy) #35

Doting on what james said. You don’t login with extension/voicemail password. It’s all done through User Manager.


#36

my fault, I didn’t use the usermanager module in 2.11 freepbx.
Actually it’s the best choice for authentication, so thanks to all
6.12.65 is up and running very well


(Hernandez IT Services, Inc.) #37

Just a note for my experience. I was running 5.211.65-2 and used the upgrade script. After all the updates, the system seemed to work but was unable to use the web interface (login page was fine but after login, it redirects to a blank config.php page). I also had the same message during the upgrade as GRZMRC, “PHP Fatal error: Class ‘FreePBX’ not found in /var/www/html/admin/modules/userman/functions.inc.php on line 14”.

I then switched back and forth (rebooting each time) between asterisk 11 and 12 but no luck getting a working GUI after login. I also ran the upgrade script a few times but still no luck with getting the web GUI working again. I noticed at the bottom of the login page it still showed 11 instead of 12. So at this point I decided to comment out line 14 in the userman/functions.inc.php file. This then led to an error with the cxpanel/functions.inc.php file so I commented out lines 48 and 49. Once this was done I was able to use the module admin on the command line and noticed almost all of the modules were out of date when using the listonline option. After updating the framework and core modules, I was able to go back and removed my commented lines from the two php files listed above.

Once those were updated, I was able to use the GUI again and updated the rest of the modules that it could update. After update, received a fatal error and had to install the COS module. After that was installed, all the issues I was was basically gone. The userpaneltab module was broken so I removed it. Also the ucp module wasn’t installed so I decided to install it. This basically fixed all the modules and now the last issue I had was with 42 modules being unsigned.

I figured now was a good time to run the amportal a ma refreshsignatures command. After executing this command, only 2 modules were unsigned, both being commercial modules that were installed but not used. So I decided to uninstall those modules. Now, no more warnings about unsigned modules. Last issue that I decided not to fix was with 11 altered or tampered CID Superfecta image files. On the command line, it basically states the following in the SETTING FILE PERMISSIONS section after running any amportal command and after Permissions OK and Removing any dangling symlinks: find: ‘/var/www/html/admin/assets/superfecta/images/off.gif’ : Too many levels of symbolic links" and it shows this for 11 files. These are the same 11 files that the main gui states are altered/tampered.

I hope this wasn’t too verbose but figured it may be helpful if someone runs into a similar issue.


#38

hernandezitservices,
I had exactly your issues.
If you “comment out line 14 in the userman/functions.inc.php file”, like I did, it leads to a partial update, and you’ll need to manually delete & upgrade all modules.

Please try to revert to your initial state: 5.211.65-2 and uninstall userman and xmpp.
Then, do all the upgrade script from 5.211.65-3 to 5.211.65-14 (optional??? I did all the script to be sure)
do the upgrade to 6.12.65.
In this manner you’ll have a clean freepbx12 GUI without any needs of intervention


(Tony Lewis) #39

I am going to add to the script to make sure userman is updated on 2.11 before going to 12. Who has a system they can test this on that was having problems before.


#40

from 5.211.65-15 (after updating all modules first), when I run the script it terminates early with this:

Module framework successfully downloaded
Module framework successfully installed
awk: cmd. line:1: fatal: cannot open file -r' for reading (No such file or directory) ./upgrade-5.211.65-to-6.12.65-13.sh: command substitution: line 112: syntax error: unexpected end of file ./upgrade-5.211.65-to-6.12.65-13.sh: line 107: -u: command not found ./upgrade-5.211.65-to-6.12.65-13.sh: line 114: [: : integer expression expected ./upgrade-5.211.65-to-6.12.65-13.sh: line 118: syntax error near unexpected tokenfi’
./upgrade-5.211.65-to-6.12.65-13.sh: line 118: `fi’

Also webGUI showing update (partially?) successful, with the shiny new interface. However it’s complaining about 44 unsigned modules, which is way more than anyone else had reported. It’s also asking me to ‘Apply’ the config, but I am afraid to do that until I have seen a successful upgrade script.


(Tony Lewis) #41

pull down the latest version of the script and try again. Looks like a extra ` got put in.