44kb call recordings

Hello All

I am currently working with FreePBX version FreePBX 13.0.101 however i have other PBX systems and this same issue is on all servers so its not version related.

I have my call recording setup like so
Inbount route (dont care)
ringroup (dont care)
queue (dont care)
Extention (force)

The idea is we don’t want to record people in the IVR or queues but rather just once they reach an agent.
however when a caller sits in queue the system keeps trying to ring agents until it finds one that is not on an active call. Now the problem we’re having with this is that every time the system attempts to ring an agent it will makes a recording for that attempt that is always 44kb. so now because i have 100 agents the system is making 100 tiny recordings for every caller.

I have created a cronjob to clear them out but this is taxing on the server and should not be happening in the first place. Does anyone know how i can eliminate the un wanted recordings ?


if [ $(stat ${MIXMON_DIR}/${CALLFILENAME}.${MIXMON_FORMAT} -c %s) -eq 44 ]; then rm ${MIXMON_DIR}/${CALLFILENAME}.${MIXMON_FORMAT} ;fi

in your “Post Call Recording Script” part of advanced settings.

I am already removing the files with a script, I am wondering how to not have them created in the first place.

any suggestions ?

You said “Don’t care” and “force”, that should probably be “no” and “yes”


I have tried that in the past but just to be sure i will try it again.