404 Not Found


Well sitting here for a couple of days trying to figure out what is going on with the Restful Apps. When I assign the XML-API to a function key I get the desired EX. http://xx.xx.xx.118:88/applications.php/donotdisturb/main?user=100 and it goes to it via the web. I have tried to use the apps and keep getting the wonderful Invalid Action URL.

Well after banging my head against my desk a few times, I checked in the phone GUI (Aastra 6757i) and noticed the XML APPLICATION URL has http://xx.xx.xx.118:88/applications/restapps/main?user=100.php and upon examining my system, there seems to be no such directory as well as I have seen mentioned in other posts I tried going to the link and I get Error 404 The requested URL /applications/restapps/main was not found on this server.

So that explains why I can’t get even as simple as Call-Fwd to work or any of the others.

Please enlighten me into what is actually supposed to be in the XML ACTION URL. It seems to me that the EPM isn’t putting in the correct request.

Do you have a valid license for Rest Apps on your system and have you followed the wiki on setting up Rest Apps.

Everything is licensed, all extensions have proper tokens and permissions
and it’s driving me insane. All ports are opened as such. Trust me I have
gone through this whole forum and triple checked each and every thing.

My last resort now is posting here so I can keep what hair I have left in
its rightful place. :frowning: