403/401 when registering with SIP

I’ve been wracking my brain against this issue for a few hours and nothing seems to be coming up.

I’ve got an extension set up with a simple secret that I copied into Ekiga. I’ve also tried using other SIP clients, with the same result. I’ve tried changing NAT settings, canreinvite, but Asterisk always returns with a 401 Unauthorized or a 403 Forbidden.

Here’s the SIP debug output: http://pastebin.com/K2jKbnUF

I’ve replaced my actual domain and the IP address I sent from with fake ones.

Searching through these forums, I’ve found others with very similar issues, but none seem to have a found a solution. Any ideas as to what I should try?


More research has uncovered this: https://stackoverflow.com/questions/15892681/mjsip-asterisknow-403-forbidden-wrong-password

My output of “sip show users” is, like the guy above, just an empty header. Clearly FreePBX isn’t saving the settings properly. I’m looking to this further. I’d still like input if anyone else has a solution to this problem.

I reinstalled FreePBX and it appears to be working properly now. I wish I knew what is different this time around, but I don’t. For future people with this issue, try running sip show users and see if any are listed. If not, try recreating your user.