%40 + account # instead of @ in invite in call attempt using voip.ms

I’m seeing a %40 instead of an @ on my sip invites.
voip.ms rejects the call.

XX.XX.XX.XX is my ip
YYYYYY is my voip.ms account number
ZZZZZZZZZZ is my caller ID

[2020-01-31 15:01:55] VERBOSE[10911][C-00000167] chan_sip.c: Reliably Transmitting (NAT) to 208.100.39.55:5060:
INVITE sip:4443%[email protected] SIP/2.0
Via: SIP/2.0/UDP XX.XX.XX.XX:5160;branch=z9hG4bK4ca1143e;rport
Max-Forwards: 70
From: sip:[email protected]:5160;tag=as48717533
To: sip:4443%[email protected]
Contact: sip:[email protected]:5160
Call-ID: [email protected]:5160
CSeq: 102 INVITE
User-Agent: FPBX-15.0.16.42(15.7.3)
Date: Fri, 31 Jan 2020 20:01:55 GMT
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLISH, MESSAGE
Supported: replaces, timer
Remote-Party-ID: “ZZZZZZZZZZ” sip:[email protected];party=calling;privacy=off;screen=no
Content-Type: application/sdp
Content-Length: 253

v=0
o=root 1576140087 1576140087 IN IP4 XX.XX.XX.XX
s=Asterisk PBX 15.7.3
c=IN IP4 XX.XX.XX.XX
t=0 0
m=audio 11522 RTP/AVP 0 101
a=rtpmap:0 PCMU/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=ptime:20
a=maxptime:150
a=sendrecv


[2020-01-31 15:01:55] VERBOSE[10911][C-00000167] app_dial.c: Called SIP/voip.ms/[email protected]
[2020-01-31 15:01:55] VERBOSE[3016] chan_sip.c:
<— SIP read from UDP:208.100.39.55:5060 —>
SIP/2.0 401 Unauthorized
Via: SIP/2.0/UDP XX.XX.XX.XX:5160;branch=z9hG4bK4ca1143e;received=XX.XX.XX.XX;rport=5160
From: sip:[email protected]:5160;tag=as48717533
To: sip:4443%[email protected];tag=as1a104286
Call-ID: [email protected]:5160
CSeq: 102 INVITE
Server: voip.ms
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLISH, MESSAGE
Supported: replaces, timer
WWW-Authenticate: Digest algorithm=MD5, realm=“chicago4.voip.ms”, nonce=“0ca111a7”
Content-Length: 0

<------------->
peers are registered:
voip.ms/YYYYYY 208.100.39.55 Yes Yes 5060 Unmonitored
voip.ms1/YYYYYY 208.100.39.52 Yes Yes 5060 Unmonitored
voip.ms2/YYYYYY 208.100.39.53 Yes Yes 5060 Unmonitored
voip.ms3/YYYYYY 208.100.39.54 Yes Yes 5060 Unmonitored
voip.ms4/YYYYYY 208.100.39.55 Yes Yes 5060 Unmonitored

FrePBX Asterisk version 15.7.3

I’m gonna guess that there’s a random parenthesis “(” in your configuration.

scrubbed my config and noticed this in the logs

[2020-01-31 16:20:43] WARNING[8697][C-00000187] ast_expr2.fl: ast_yyerror(): syntax error: syntax error, unexpected ‘>’, expecting ‘-’ or ‘!’ or ‘(’ or ‘<token>’; Input:
“SKIPTTL”=“LIMIT” & 3 & 0 & >0 & 0>=
^
[2020-01-31 16:20:43] WARNING[8697][C-00000187] ast_expr2.fl: If you have questions, please refer to https://wiki.asterisk.org/wiki/display/AST/Channel+Variables

I have seen this before and it was fixed by an asterisk restart

2 Likes

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.