3rd Party Voicemail

Hello all,

I am running trixbox (which is not true freepbx but the trixbox support forum is going no where with this) version 2.8.0.4. Asterisk version 1.6.0.26

I have a SIP based 3rd party voicemail which is working great through a SIP trunk. The last step is to have calls ringing my phone to forward to this 3rd party voicemail after 15 seconds.

I have the following for matching any 1XX extensions and I put this in extensions_custom.conf but it doesn’t seem to be working.

[local-custom]
exten = _1XX,1,Dial(SIP/${EXTEN},15)
exten = _1XX,2,Dial(SIP/${EXTEN}@TOLEE8,15)

Would this be right or is there a better way?

Thanks.

Well, I found a site that shows how to integrate trixbox 2.8 with Exchange and stole the tips from it.

It’s actually changing part of the extensions.conf macro for voicemail and I’m sure it would work for a custom destination as well but the instructions say to change

exten => s,n,Macro(vm,${VMBOX},${DIALSTATUS},${IVR_RETVM})

to

exten => s,n,SIPAddHeader(Diversion: tel:${EXTTOCALL};reason=no-answer;screen=no;privacy=off)
exten => s,n,Dial(SIP/tolee8/780)
exten => s,n,Hangup

Which works great.

Other than adding the diversion header that’s exactly what I was showing you to do.

You need to put the changes in extensions override or they will get over written!

I tried [email protected] or [email protected] and neither worked though. With voicemail enabled from extensions, it still goes to meridian mail and with voicemail off, it doesn’t forward. I’ll try it again and see.

Maybe I’ll make a brand new extension and try it.

Sorry, the format of mailbox is [email protected]

You were on the right track. What you need to do is to create a custom context that dials your VM system with a SIP URI

[custom-vm]
exten => s,1,Dial(SIP/TOLEE8/${EXTEN:1})
exten => s,n,Hangup()

Check my syntax on the dial command, did this from memory

Bah, so I created the above in extensions_custom.conf and I made a custom destination of custom-vm,s,1 unless it should be something else.

It does ring the trunk properly but still no call info.

The strange thing is that my initial post context has worked on other systems and just doesn’t work on this one for some reason.

Wow, I gave you the answer. You don’t need a trunk. Just do a URI dial in the voicemail field like I showed you.

I think you can use the “mailbox” field in the extensions settings such as “[email protected]

I would test first with just the IP and then with a hostname.

Tried it but it didn’t work. If I have voicemail disabled, it never transfers but with it enabled just goes to median mail

Let me get the concept straight…

When you get a no answer, you want it to go to an outside voicemail provider. I understand that, but what are the mechanics of accessing the outside VM provider.

What I’m hearing is that you have to hit a specific trunk and then dial a number?

Or am I all wet here.

If I understand the mechanics right, I may be able to come up with a (reasonably intelligent???) solution.

Bill

I have a trunk set up with the following:

host=192.168.10.248
context=from-internal
qualify=yes
type=peer
dtmfmode=rfc2833
disallow=all
allow=ulaw
nat=no

I have an outbound route set up for 780 to to out that trunk so direct calls to the trunk and calls from the trunk work great. The only issue I’m having is forwarding no answer calls to said trunk with diversion information so voicemail knows it’s a no answer call.

Thanks for your help.

Once you hit that trunk what has to happen?

Bill

I’m not sure what you mean by that. The trunk to voicemail is just to voicemail, doesn’t have anything else.

The voicemail just needs to see a call to voicemail from the user who called the other user and a diversion header with no answer from the extension that was called.

For the To: in the SIP invite, I can change the voicemail accordingly to react to that but the history is what I need.

Thanks.

Can’t you use the Followme function.

I would but there’s no way to forward to a trunk if no answer.

Would I have to make a custom app?

Edit: Nevermind, I made a misc destination and it showed up in follow me, let me test

I made a misc destination but there’s no call history in the SIP information so the voicemail sees the call as a direct call and not a no answer