[2019-08-21 10:53:44] ERROR[22141] res_pjsip.c: Unable to retrieve PJSIP transport 'udp,tcp,ws,wss'

Hello! i tried to fix this problem by looking at the past topic that are similar to my problem and tried to fix it base on the answer that was given by other users. But, it seems like i cannot fix this… is there any other suggestion to fixt this problem??

Thank You

[2019-08-21 10:53:44] ERROR[22141] res_pjsip.c: Unable to retrieve PJSIP transport ‘udp,tcp,ws,wss’

It’s weird. I was just helping another guy with this - you’re the second person today that’s having the problem.

Hmmmm. Since it’s more than one person having the problem, you probably need to spend some money on support credits to get this looked at. If it was just one person, we could probably help, but since there’s two, it must be a systemic problem that we can’t solve.

1 Like

enable those transports in pjsip channel specific asterisk sip settings ?

1 Like

Okay thank you for you replay though. I guess i would spend little more time before spending the money.

You could start up yet another third new thread with exactly the same information…

1 Like

I did try switching to all yes, but it did not fixed it…

But thank you!!

Everything worked before i update or renew the certificate. Everything start not working after. So i am really mad and confused on whats really going on.

I openend a bug report a while ago on an invalid PJSIP transport udp,tcp,ws,wss being assigned to the anonymous context if allow guests=yes.


1 Like


So i did change the allow guests to be no but it still does not work :disappointed_relieved:

But thank you!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.