2 Problems. To make a call and echo

Hello, I have the following problems.
I have 4 phone lines, 2 phone lines from one company and another 2 lines of another company (the 4 lines are analog)

I have the lines of the “Company 1” on ports 1 and 2 and “Company 2” ports 3 and 4. (TDM410)

I have two problems.

Problem 1:
To be in use lines 1 and 2, I like to make a call does not take the lines 3 or 4, 486 appears Busy phones (Grandstream GXP1400 phones are).

If disconnected from the power lines 1 and 2, and I want to make a call I have the same message.

I have the 4 Trunks configured the same way, the only thing that changes is the “Trunk Name” and “Zap Identifier”.

In outbonds Routes, I have configured the 4 phone lines

I Create one outbond have prefix 6666 and only have lines 3 anf 4, and so if they work, so that this rule Trunk misconfigured.

I dont have idea to try now.
No longer do to make it work.

Problem 2:
Lines 3 and 4 are new lines were installed 15 days ago.
When we make a call on these lines or when we receive a call on these lines, the other person listens and hears us perfect. but we hear our own voice echo, we hear the other person perfect but own voice whit echo.

i Find info of echo on internet, but information speak of zapata.conf, but if I understand I have the new versions of FreePBX longer use more Zapata

thanks in advance
And Sorry for my English

If I am understanding you correctly, I believe what you want to do is:

  1. Create two different trunk groups in the file /etc/asterisk/dahdi-channels.com. For example you would have Company A with group 0, and Company B with group 1.

  2. In “Trunks” in FreePBX, create a trunk for both g0, and g1 for each appropriate company.

  3. Create two different extension types. Company A: 2xx and Company B: 3xx for example.

  4. In “Outbound Routes” in FreePBX, in the field “CallerID” you can specify which extensions should go out which Trunk Group. For example you could put “3XX” in the CallerID field so that it matches all outgoing calls from 3xx extensions and sends them out Trunk Group 0.

Regarding the echo, do you have an echo cancellation module on your Digium Card? If not I would highly recommend it, as it generally eliminates all echo on analog lines.

You could should also try tuning your digium card. See here: http://kb.digium.com/articles/Troubleshooting/how-to-basic-fxotune

Sorry maybe I express wrong.

I have 4 Lines (2 “Company 1” - To 2Company 2")
When a person make a call to any number the FREEPBX, take a “Company 1 Line 1” - when other make another call the FREEPBX, take a “Company 1 Line 2” - when other tray to make a call and the “Company 1 Line 1 and 2” are in use, the FREEPBX are configured to take a “Company 2 Line 1” but in the Granstream phone i recibe a messagge says “486 Bussy”

Thanks in advance and sorry for my english.

I dont have Echo Cabceler i now see the document and try.


Do you have busy call forwarding enabled on your lines or a hunt group? For example from your phone company you would want to have the following setup:

Company 1 Line 1 -> Busy Call forward to Company 1 Line 2
Company 1 Line 2 -> Busy Call forward to Company 2 Line 1
Company 2 Line 1 -> Busy Call forward to Company 2 Line 2
Company 2 Line 2 -> Busy Call forward to Company 1 Line 1

Or have them configure what is called a “Hunt Group” which they determine which lines are busy from their end.