2.7 Backup

Since upgrading to 2.7 my weekly backups have changed from 40,000 kb to 2500 kb this must only be a partial backup of what I was getting before.
Basic Settings

Schedule Name: x
VoiceMail: x
System Recordings: x
System Configuration: x
Admin Web Directory:
CDR: x
Operator Panel: x

All except (Admin Web Directory) is selected, if I select this then the file jumps to 50,000 kb but how do I tell if my backup is complete. The fly over says its for static web files ? I don’t want to do a restore to find out if it works or not has any one done a successful backup and restore with 2.7


the best way to find out is to try it of course…

but, you can explode the tarball, which may result in other tarballs inside the top level one to be exploded and examined.

They should all be expanding into a subdir under /tmp somewhere so it should not overwrite your config. You should be able to obtain from the files there what is being saved and not.

You asked if someone had done a successful backup and restore with 2.7. I built a new server a week ago for a client. The server ran flawlessly for 4 days at my office so I took a full backup using the 2.7 backup tool via the web interface. I unplugged the server, took it to the client’s office and plugged it in (without connecting a monitor).

The customer’s building was still in the process of construction but we were planning to go live in a few days. I plugged the server in (without a monitor), connected it to the internet and left. At 10pm the night before going live I tried to connect remotely but the connection failed. I went to the office and found the RAID controller failed to initialize and no amount of rebooting or BIOS flashing would resolve the problem.

I always thought the backup feature was nice but always assumed if something went terribly wrong that the backup took would only take me so far. I could not be more wrong. I installed FreePBX from the ISO, did all the updates, copied the backup file back to the new machine, clicked RESTORE, selected the backup archive from the list and restarted Asterisk/httpd. The restore worked flawlessly! I thought I would have several hours of work ahead of me but I was able to finish the new server within the hour.

I did want to take the opportunity to thank the FreepBX and Asterisk developers and contributors for an awesome framework of tools and features. This product (along with countless hours of reading, troubleshooting and documenting my experiences with Asterisk itself) has fed, clothed and sheltered my family through one of the worst recessions in US history. Thank you!

The backup utility works great. We use it in commercial production with a 3 hour SLA.

If you look in amportal.conf you can configure backup to FTP.

We paid a developer to install a script on our server that runs FTP that displays a HTML “portal” with the backup status of all the PBX’s we have under management. Information includes date and time of last backup and storage used. An additional cron job prunes the backups and keeps the space under control.

It does not seem to restore any additional folders/files during a restore.

Am I missing something?

I used the Backup and Restore in 2.7 with the hope of creating a cold-swap standby system (create an identical system and if the prime server fails, unplug it, plug the new one in and voila.

So I created the prime system, ran a full backup, including some additional folders (see below). I recreated the backup schedule on the standby system, transferred the .tar file from the prime system to the /var/lib/asterisk/backups/ and ran a restore on the standby system.

This worked fine for the base system, but I had three additional folders
that I have files in that I also wanted restored.

When I ran the restore on the standby system, all the basic FreePBX configs were restored but none of the additional files/folders were restored.

Any ideas?