2.11 to 12 upgrade tool issue

I have a somewhat older installation of the FreePBX distro. I think I am on this End of Life unsupported track:


and had previously updated to the last step in this chain.

Today when I did an upgrade of my modules, I noticed an module that woull upgrade me from 2.11 to 12. I got excited and installed and tried to run this module. Now I seem to be sort of stuck. After starting the “upgrade”, I was able to upgrade the FreePBX Framework to version 12.0 (12.0.29) but my FreePBX Core is stuck at If I go to the Admin → Modules Admin, I only see the Framework module and the commercial System Admin module:

and can’t see any other modules to upgrade. Am I hosed at this point? – Bud

Click “check online”

Click “check online”

Thanks for replying. Sorry, should have mentioned that I did this as well but that just shows that the commercial System Admin is upgradeable:

Here is a shot of the System Status screen too:

Go to the cli


amportal a ma update core

Thanks Andrew. At first I seemed to be having issues hitting the mirrors but after a bit of ‘hand wringing’ and googling, I found that:

Advanced Settings > “Use wget For Module Admin” > false

solved that issue. Then I struggled trying to reload the config changes until I realized I need to upgrade the rest of the modules first. Sees to be all good now! Thanks again. – Bud