2.10 upgrade issue

I was not able to locate anything concrete on this, so I hope someone can inform me of what needs done.

I just ran the 2.10 upgrade and I have a couple of modules that will not install… Reason or error is…

System Admin cannot be upgraded:
PHP version 5.3.0 or higher is required, you have 5.1.6
PHP Component Zend Guard Loader is required but missing from you PHP installation.

Please try again after the dependencies have been installed.

Question being, is it safe to Yum update php or should I do something else?

Many thanks…

What Distro are you using? yum updates are always dangerous and your Distro may not even have php 5.3 support.

If using the FreePBX Distro than use these scripts to update versions. http://www.freepbx.org/forum/freepbx-distro/distro-discussion-help/release-versions

The distro is 1.6 ISO from FreePBX

I should quote my version…

Asterisk (Ver.
PBX Firmware:
PBX Service Pack:
PHP Version 5.1.6

You need to follow the upgrade scripts found on that link I posted above. You are behind on a lots of updates.

Without sounding like a moron… how do I run them updates? still newish to freepbx.

My version is so I presume I need to run http://upgrades.freepbxdistro.org/stable/ and follow with the rest?

Opps, I figured it out, downloaded the file and ran bash, just completed the first one… so i guess I am on to the next one now.

OK, upgrade went well, but I am now seeing this in the FreePBX notice panel

Could not run admin script.
Exit code was 127 and output was:

Added 46 seconds ago

Any idea what this is about?

I’m getting the same Exit Code error.

Can you check Advanced Settings, under “Developer and Customization” category. Do you have anything set in your PRE_RELOAD Script or POST_RELOAD Script settings?

oops … looks like the module version of framework didn’t get bumped, pull it down again and if still failing then provide the requested information. Sorry.

Everything seems fine now! I updated that framework and everything is PEACHY! Many Thanks. You guys ROCK :slight_smile:

Do you have any information on how I/we should look for updates? I would like to try to keep up with the new updates in future.

Trouble with me is, if it’s not broke… I leave it alone… lol

I had the same issue, but once I re-installed the framework module, the error went away.


That link appears to be broken or the page removed.

Hello All,

I have the same problem on 2 systems.
Both have been script upgraded and running on 1.814.210.58-2.

One does not show an option for sysadmin to install and the other complains that zend-guard is not installed when trying to install system admin.
I see physically that the same version of zend-guard is on the 2 boxes that are having the issue as well as on a stable box via rpm -qa.
I reinstalled the RPM for zend-guard with no difference.

Any suggestions?