2.10 Beta

Have found some time to start looking at 2.10 in more depth, I can’t seem to find System Admin in the menu structure. I think I have read through all the information and posts that appear in different places regarding the 2.10 Beta but have not found reference to this. Could someone point me in the right direction please?

I read Phillipes Astricom blog in which he mentions hovering being introduced for the menu items, I don’t see this in the latest update. Could someone confirm that its not there yet?

Could I suggest that we all post in the same place regarding 2.10? It seems to me that right here in the Beta forum is the right place or is there a reason for it being somewhere else?

Looking over everything 2.10 should have Sysadmin available in the Commercial repository however it wasn’t rolled with the initial release of the beta.

OK found the module in the commercial repository and have loaded it without problem.

Some small points:

After completing tasks in Module Admin you are returned to a start page that is a bit confusing. It would, I suggest, be better if a task completed page were displayed.

On the Trunk Module would it be possible for the Trunk Listing Box on the right to expand to avoid truncation of longer descriptions as do the boxes on inbound and outbound routes?

Is there a writeup on the operation of the backup module, am finding its operation difficult to understand?

Otherwise testing is going well and I am becoming more comfortable with the new look and feel.

Just tried to make some changes on the advanced settings page and find the green save arrow does not appear after making the change so I can’t actually save the change. I tried with Chrome, Firefox and IE8, same with all of them.

Anyone else experiencing this or am I missing something?

I am having the same problem, also in FOP2 admin you can’t check the boxes to disable any objects.

I think a global framework issue exists.

I will get with gamergamer and see what he has to say.

Can you guys let me know what framework your on as well as verify that you don’t have the red apply changes bar? Reason I ask is I just tested an install from over the weekend running the 2.10beta2 framework and don’t have the issues described in this post. We are however aware of issues with SIP Settings and IAX Settings modules which we are looking into.

OK, I have the red apply changes bar.

Will send you over the data.

I’ll try to roll a new framework tomorrow, there has been at least one or two issues though it should not be related to the problems you are describing, there are issues with agi-bin scripts not being copied, a previous bug that appears to have been accidently reverted a few weeks ago when some other cleanup work was being done.

Do make sure to for refresh the browser as there were some javascript issues that I encountered just before rolling beta2 that required the cached versions to be flushed. Advanced settings was one of the affected modules.

Will check Framework version and browser cache later this morning. My problem is that the u shaped green save arrows are not appearing in the Advanced Settings. The column to accommodate them is there put remains empty.

The red bar is appearing when one would expect it.

I think it unlikely the issue is associated with browser cache as I tried three different browsers (Firefox, Chrome and IE8) during the course of my investigation but I will run some more tests later this morning and revert back.

I was at 2.10.0beta1.0. Was able to upgrade to 2.10.0beta2.2 and arrows have appeared as expected. Now doing some detailed testing.

It seems to be OK now.

I am looking at the Styling and Logos, it seems to me that some of it is no longer appropriate with the new GUI layout. The only place I was able to insert a logo was to replace the bottom left FPBX logo which I don’t want to do.

I do like to put my own logo on the screen but at the same time keep the branding that is already there, any ideas how I can achieve this?

I was unable to upgrade to the 2.3 framework… something broke while applying config… haven’t figured it out yet

hmm peculiar… after several hangs it 2.3 framework did actually update. now apply config hangs for about 20 seconds before doing anything… had this problem once before and it “fixed itself”… confusing.

Something is broken in the latest update.

I had a similar problem - take a look at:


After I loaded to latest update to the distro everything was fixed.