183 with SDP causing "All Circuits Busy" - how to disable this 183 early media on FreePBX

FreePBX 15.0.23, Asterisk Version: 16.24.1

After hours, calls should be forwarded to a Misc Destination from a Set CallerID (goes to after hours cell phone), but the connection immediately says all circuits are busy.

We use pjsip and this used to not be any issue, it worked, and nothing I can think of changed, but now we have this “all circuits are busy” issue after hours when calls are forwarded via Time Condition (it works fine if after hours is set to go to voicemail)

Does anyone know how “disable this 183 early media on FreePBX”, per Flowroute’s suggestion:

“We have found the call and we are seeing your FreePBX system is sending a message (183 with SDP) and then Flowroute a 503 message. After we get the 503 message we try to route the call to the failover route but the originating side is ending the call before the forward can be sent. It appears that the FreePBX is sending the message All Circuits are Busy in the 183 with SDP that it is sending before the 503. If you can disable this 183 early media on FreePBX the message should go away.”

Getting 503 is something you get on outgoing calls. Sending 183 is something you do on incoming calls. I don’t see how the latter can cause the former.

The attempt on the outbound leg failed, so FreePBX played “All circuits are busy now …” to the caller, followed by a 503. Upon hearing the message, the caller hung up, so Flowroute’s attempt at failover did not succeed.

If you just eliminate the 183 (or change the message to something like “please wait while your call is connected”), Flowroute’s failover would succeed.

However, that’s not what you want. You need to find out why the outbound attempt to the Misc Destination failed. I’m guessing that the provider (is it also Flowroute?) or the terminating carrier is rejecting the call because of the caller ID you are sending.

If your call flow is Inbound Route → Time Condition → Set CallerID → Misc Destination, this should work provided that you are setting CALLERID(num) to your main number, in the format required by the outbound provider.

If you still have trouble, at the Asterisk command prompt type
pjsip set logger on
make a failing call, paste the Asterisk log for the call at pastebin.freepbx.org and post the link here.

OK, in Set Caller ID we have CallerID Number set to ${CALLERID(num)}

This worked in the past, but based on your suggestion, I could literally try setting it to the main number, the primary reason we did this as I recall, was to get the actual caller-id to the cell phone, in case of a lost connection, we had a way to call back. I seem to recall that was the way it worked, but whatever, it used to at least send the calls w/o issue.

If that doesn’t work, I will do this, but I cannot test it until later this evening, thanks:

If you still have trouble, at the Asterisk command prompt type
pjsip set logger on
make a failing call, paste the Asterisk log for the call at pastebin.freepbx.org and post the link here.

Things have changed, arbitrary CallerID’s might well not be accepted by VSP’s following current legal compliance try first using one you have with your provider. For thisa I suggest thye higher level sngrep over SIP level debugging.

I will try that this evening for sure, and reply here tomorrow… Thx

OK, I got too tired to debug much, but hard-coding the CallerID Number in Set Caller ID did not help. So I tired a Ring Group istead, and that works, so I quit for the night.

Well, though Ring Group does not get the “All Circuits Busy” error, it is only ringing the first line in the ring group even though it is set to ringall

Anyone have a clue what I might be doing wrong?

So it is 3 cell numbers in the Ring Group, for example, like


and only actually calls 17035551212#


Logs? we always need logs :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.